[repost] Fresh install of 6.1/amd64 - Xorg driver problem with Nvidia 7600 GS (stock nv driver)

danny webster dannywebster at googlemail.com
Tue Jun 6 14:07:03 UTC 2006

Hi all,

Apologies for the repost (and slightly corrected) mail from freebsd-x11 -

I recently built a new box, with A8N32-SLI Deluxe mobo, PCI-E geforce 7600 GS

CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 4400+ (2210.07-MHz K8-class CPU)
avail memory = 4000612352 (3815 MB)

.. and built to 6.1-STABLE (including options SMP).  The default Xorg
which is installed at install time is broken on my machine.  A
'xorgcfg', or testing the xorg.conf.new spews the following error,
then sigabrt's.

"Fatal server error:
Caught signal 8.  Server aborting"

I have also removed the package Xorg, tried the one built from ports,
but same error.  Also, I tried xorg-server-snap, but same problem.

Here's a backtrace from the core via gdb.

#0  0x0000000800ca6c9c in kill () from /lib/libc.so.6
#1  0x0000000800ca5b2d in abort () from /lib/libc.so.6
#2  0x000000000042cb05 in ddxGiveUp ()
#3  0x00000000004a6df3 in AbortServer ()
#4  0x00000000004a6f41 in FatalError ()
#5  0x00000000004442d1 in xf86SigHandler ()
#6  <signal handler called>
#7  0x0000000801f825c8 in nvGetClocks () from
#8  0x0000000801f83588 in NVCalcStateExt () from
#9  0x0000000801f7d6ba in NVDACInit () from
#10 0x0000000801f7c905 in NVModeInit () from
#11 0x0000000801f7ceb4 in NVScreenInit () from
#12 0x000000000048e14f in AddScreen ()
#13 0x000000000042e038 in InitOutput ()
#14 0x000000000048dae5 in main ()

.. and here is what is reported from pciconf -lv

none11 at pci3:0:0:        class=0x030000 card=0x22211682 chip=0x039210de
rev=0xa1 hdr=0x00
    vendor   = 'NVIDIA Corporation'
    class    = display
    subclass = VGA

the "none11" part fills me with suspicion - is there a specific kernel
config option to use with PCI-E devices?  Apart from this, everything
else works just fine (apart from nve0 instability, but i don't use the
i/f...</OT>).  The BusID's are correct in the xorg.conf (as per
pciconf output).  This is most likely an unsupported chipset (although
nv(4) does mention the GeForce 7XXX series, albeit the G70, but I
believe my card is that very one).

I may try and graft in the nv driver from Xorg R7.1 if at all there's
been any progress with it since 6.9.0.

I can use X with the vesa driver, but value my eyesight and therefore
will endeavour to get this cracked with nv.

I'd appreciate any pointers in the right direction

Thanks for your time.


More information about the freebsd-stable mailing list