Sound device reported but no devices created

Ian Smith smithi at
Sun Jul 30 13:44:44 UTC 2006

On Sun, 30 Jul 2006, Peter Jeremy wrote:
 > On Sun, 2006-Jul-30 17:52:27 +1000, Ian Smith wrote:

 > > device          sound
 > > device          snd_sbc                 # ES1869 (Compaq OEM)
 > >
 > >but after much headscratching it only finally worked after adding:
 > >
 > > snd_ess_load="YES"      # this fixed it .. bridge driver for ESS
 > That worked, thank you.  The man pages are not the clearest here.

Indeed; I'd spent days googling around lists and pages, at last found:

about the 1750, which was wrong (for the 1500c) about the device hints -
for unbridged devices, says sound(4) - but the needed clue for loading
both snd_sbc and snd_ess.

 > snd_ess(4) implies that all three drivers are needed but snd_sbc(4)
 > has no reference to it - which is what confused me.

snd_ess(4) has been updated then; at 5.4 it didn't mention snd_sbc.

Building a 5-STABLE world right now, I'm a bit curious as to which of
the more recent sound stuff has found its way into 5.5 .. hi Ariff!

Cheers, Ian

More information about the freebsd-stable mailing list