Make World Fails on Man Pages

Mark Andrews Mark_Andrews at
Thu Jan 26 19:35:32 PST 2006

> Here is a snippet of my failed installworld logs as I move to 6.0R:
> install -o root -g wheel -m 444 crypt.3.gz  /usr/share/man/man3
> /usr/share/man/man3/crypt_get_format.3.gz -> /usr/share/man/man3/crypt.3.gz
> rm: /usr/share/man/man3/crypt_get_format.3: Not a directory
> rm: /usr/share/man/man3/crypt_get_format.3.gz: Not a directory
> I get the same error from a couple other man pages (e.g. bwrite) if I 
> run make from the directory where the pages source exists.  Not all man 
> pages cause an error, just some.  I tried removing /usr/obj for a fresh 
> build since this was a former 5.4R box.  Cvsup isn't fetching any new 
> sources so I must be up to date.
> Any ideas why some man pages won't install?

     From unlink(2).

     [ENOTDIR]          A component of the path prefix is not a directory.

> Thanks,
> Jason
> _______________________________________________
> freebsd-stable at mailing list
> To unsubscribe, send any mail to "freebsd-stable-unsubscribe at"
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: Mark_Andrews at

More information about the freebsd-stable mailing list