gvinum/vinum on 6.0

Brian Szymanski ski at mediamatters.org
Wed Jan 11 04:00:35 PST 2006

Stijn, thanks for your help, I'm getting closer...

>> I took 6.0 for a test drive today and was disappointed to find that
>> vinum/gvinum are still in disarray. For example there is a man page for
>> vinum, but only a gvinum binary. gvinum help still lists lots of old
>> vinum
>> commands that are not implemented in gvinum. Lots of basic things I try
>> from the gvinum prompt just tell me "not yet supported".
> Hmm. There is a manpage in 6-STABLE. And there are a few things that
> don't work but I wouldn't call it "lots".

Ah, a manpage! Progress...

>> But most importantly, gvinum configuration (at least for a raid-5 plex)
>> still doesn't persist across a reboot :(
> That's a bug; I think it might be related to compiling gvinum in the
> kernel
> as opposed to loading it from /boot/loader.conf. I also think there is a
> fix already commited to 6-STABLE.

Hmm, I upgraded to 6-STABLE and I'm still having the problem.

Here's basically how it happens:
gvinum create /etc/vinum.cnf
newfs /dev/gvinum/VOLUME
mount /dev/gvinum/VOLUME /mnt
#screw with /mnt, everything works and is happy, yay!

At this point I call "gvinum l" (which loads geom_vinum.ko) by hand (after
the reboot). My configuration mostly seems to persist - except or the
"drives" section...

One of two things happens here: Either
a) The volumes/plexes appear down, the subdisks are stale. Additionally,
/dev/gvinum is not there - suffice it to say I can't mount anything.
b) Everything has status up (except the nonexistent drives). In this case
as well, /dev/gvinum is not there - and I still can't mount anything.

If I try to fix the configuration by gvinum rm'ing the volumes and plexes
that are there, then reloading my vinum.cnf (gvinum create), either:
a) everything seems to work
b) the system panics

Unfortunately there is no correlation between "gvinum l" output and
whether the system panics or is happy when I run gvinum create again.

Would I have better luck compiling gvinum into the kernel instead of
loading the module? What do other folks who have successful config's do?

Thanks in advance,

Brian Szymanski
Software and Systems Developer
Media Matters for America
ski at mediamatters.org
-------------- next part --------------
A non-text attachment was scrubbed...
Name: vinum.r5.cf
Type: application/octet-stream
Size: 213 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-stable/attachments/20060111/04fdb273/vinum.r5-0001.obj
-------------- next part --------------
A non-text attachment was scrubbed...
Name: gvinum.before
Type: application/octet-stream
Size: 578 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-stable/attachments/20060111/04fdb273/gvinum-0002.obj
-------------- next part --------------
A non-text attachment was scrubbed...
Name: gvinum.after
Type: application/octet-stream
Size: 405 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-stable/attachments/20060111/04fdb273/gvinum-0003.obj

More information about the freebsd-stable mailing list