6.0 hangs at boot on Toshiba laptop

Olivier Boudeville olivier.boudeville at online.fr
Fri Jan 6 11:00:07 PST 2006

Hi everybody,

I tried to install on my laptop (Toshiba M60-176) FreeBSD 6.0 STABLE and 
it failed despite careful installation and web/archives search. It is a 
multiboot installation (Windows XP/Linux Ubuntu/FreeBSD) driven by GRUB 

After the whole installation process ended, the reboot is performed and 
the bootstrap goes until the FreeBSD menu is displayed. Whatever the 
chosen option (default, without ACPI, fail-safe, verbose, etc.) the 
system hangs immediately. For example with the first choice, we have :
/boot/kernel/acpi.ko/boot/kernel/acpi.ko text=0x40c2c data=0x2160+0x1090 
[..] and everything stops. The situation is explained very clearly here 
: http://marc.theaimsgroup.com/?l=freebsd-mobile&m=113177565322135&w=2

I do not think it is related to GRUB (the real boot has started, this 
version allows for UFS2 access, various GRUB settings have been tried, 
unsucessfully) nor to ACPI since even when disabled, thanks to the 
relevant menu option, the boot hangs as well (same behaviour, without 
the ACPI module line being displayed). I cannot disable Legacy USB in my 
BIOS, if ever it was a common workaround.

If it can help, I detailed my full installation process here : 
(by the way, there seems to be a bug when aborting/restarting under 
sysinstall : apparently in some cases it tries to install FreeBSD on the 
ramdisk instead of the requested slice).

Thanks in advance for any hint,
kind regards,


More information about the freebsd-stable mailing list