Vlad marchenko at gmail.com
Wed Aug 16 15:51:40 UTC 2006

I just got the message it panics with:

ad4: TIMEOUT - WRITE_DMA48 retrying (1 retry left) LBA=380273047
error=10<NID_NOT_FOUND> LBA=380273047
g_vfs_done():ad4s1a[WRITE(offset=194699767808, length=2048)]error = 5
panic: newdirrem: not ATTACHED

Also, you maybe very right about conflict with other hardware - it
seemed to me that it's much less stable when intense HD operation is
combined with network activity (i.e. downloading file via samba). I've
tried to copy 3gig of archives over the net and I could not copy it
after 3 attempts. Same time I've un-tarred those files locally on that
server successfully after my 1st attempt.

Any recommendations on what ~ 30 buck SATA card works OK with 6.1? I
may opt out to take this one back and replace, unless someone willing
to nail this down - I'm open for tests...

On 8/16/06, James Seward <jamesoff at gmail.com> wrote:
> On 8/16/06, Vlad <marchenko at gmail.com> wrote:
> > I get this type of messages in on my FreeBSD.
> > ad4: TIMEOUT - WRITE_DMA retrying (1 retry left) LBA=70938623
> > Under steady IO load it panics, that started when we changed SATA
> > controller (FreeBSD detects it as SiI 3512). I've tried to switch
> > ports, cable, move card into a different PCI slot, disable ata dma in
> > /boot/loader.conf - nothing helps.
> I had similar problems under 5.x and 6.x with a SI3112. My testing and
> investigations back then suggested that some combinations of hardware
> and the SI3112 just "don't get along" and I solved it by getting rid
> of it.

More information about the freebsd-stable mailing list