ACPI problems with Dell laptops

Eric Anderson anderson at
Sun Nov 27 13:13:35 GMT 2005

Greg 'groggy' Lehey wrote:
> On Saturday, 26 November 2005 at 20:25:58 -0600, Eric Anderson wrote:
>>Greg 'groggy' Lehey wrote:
>>>I've had both Dell and ThinkPad (no longer IBM).  I prefer Dell,
>>>despite their attempts to convince me otherwise.
>>>However, we currently seem to have significant ACPI problems with Dell
>>>laptops.  I'm writing this on an Inspiron 6000 running 7-CURRENT, but
>>>the same problems occur with 6.0: if I enable ACPI, timing goes to
>>>hell, and some things just time out.  There was a similar message a
>>>couple of days ago from an owner of (I think) the latest Latitude
>>>machine, which sounded even worse.  My requests for feedback about how
>>>to solve the problem have so far not been resolved.  If you're
>>>otherwise tending towards Dell, I'd suggest you watch this space until
>>>there's some indication that the problems will be resolved.
>>Which scheduler are you using?
> The standard (ULE).  I don't think the problem's related to the
> scheduler: it shows all the signs of being an interrupt space problem.

Fine - I'm just offering the parts that I recall working around it for 
me - if you are unwilling to at least try it, maybe someone else can and 
report back so we know if it is or isn't related.

>>Also, have you tried disabling apic?
> I think you mean ACPI.  This machine doesn't have an APIC.

No, I meant apic.  I realize it doesn't have one, but did you try 
disabling it?

> To answer the presumed question: Yes, as I said above, the problems
> only occur when I enable ACPI.
> Since then I've also discovered that the builtin wireless card doesn't
> work either.  It's:
>   iwi0: <Intel(R) PRO/Wireless 2915ABG> mem 0xdfcfd000-0xdfcfdfff irq 10 at device 3.0 on pci3
>   iwi0: Ethernet address: 00:13:ce:46:28:49
> After downloading the firmware, I can set IP addresses and such, but
> I always get "no carrier":
>   iwi0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> mtu 1500
>         ether 00:13:ce:46:28:49
>         media: IEEE 802.11 Wireless Ethernet autoselect
>         status: no carrier
>         ssid "" channel 1 (2412)
>         authmode OPEN privacy OFF deftxkey UNDEF powersavemode OFF
>         powersavesleep 100 txpowmax 100 txpower 100 rtsthreshold 2346
>         fragthreshold 2346 -pureg protmode CTS -wme roaming AUTO bintval 0
> When I run dhclient on the interface, I get:
>   DHCPDISCOVER on iwi0 to port 67 interval 6
>   DHCPDISCOVER on iwi0 to port 67 interval 15
>   send_packet: Network is down
> On the console I get the detailed error message:
>   iwi0: fatal error
> This machine also has Linux on it, and the card works fine with Linux,
> so it's obviously a FreeBSD-related problem.

I also had problems with it.  I ended up replacing it with a mini-pci 
atheros card.


Eric Anderson        Sr. Systems Administrator        Centaur Technology
Anything that works is better than anything that doesn't.

More information about the freebsd-stable mailing list