xorg-clients conflicts with xterm (patch)

James Long james_mapson at umpquanet.com
Tue Nov 15 19:26:24 PST 2005


After hours of head-banging over the past couple of days,
I have finally succeeded in installing EITHER 
xorg-clients-6.8.2_1 OR xterm-206_1.  Previously,
installing either port told me that it conflicted
with the other, in spite of having cvsupped my 
ports tree twice to ensure I was getting the most
recent version of the ports, hopefully including a
fix to the chicken-and-egg problem noted in 
/usr/ports/UPDATING

Once I spotted an odd bit of output in the portupgrade
dialogue, I made a change to xorg-clients Makefile 
which allowed everything to install.  pkgdb -F afterwards
and all my dependencies are tidied up.

May I suggest the following patch to 
/usr/ports/x11/xorg-clients/Makefile:


--- Makefile	Sun Nov 13 21:47:34 2005
+++ foo	Tue Nov 15 19:19:37 2005
@@ -18,7 +18,7 @@
 MAINTAINER=	x11 at FreeBSD.org
 COMMENT=	X client programs and related files from X.Org
 
-RUN_DEPENDS=	xterm>0:${PORTSDIR}/x11/xterm
+RUN_DEPENDS=	xterm:${PORTSDIR}/x11/xterm
 LIB_DEPENDS=	png.5:${PORTSDIR}/graphics/png \
 		Xft.2:${PORTSDIR}/x11-fonts/libXft
 


More information about the freebsd-stable mailing list