Swapfile problem in 6?

Kris Kennaway kris at obsecurity.org
Tue Nov 15 14:40:50 PST 2005

On Wed, Nov 16, 2005 at 09:26:43AM +1100, Johny Mattsson wrote:
> On 11/16/05 07:49, Lars Kristiansen wrote:
> >I had an infinite while loop running during the
> >kernel compilation, printing out 'swapinfo' every
> >15 seconds. The last output before the machine goes
> >dead is this:
> >
> >/dev/ad0s1b         39848    11820    39848    30%
> >/dev/md0           131072     5908   131072     5%
> >Total              170920    17728   153192    10%
> Quite possibly not related, but on 5.4 I can reliably cause a panic by 
> attaching md0 to a file residing on an NFS drive and then use it for 
> swap. After 3-5k of used swap on md0, the box dies and reboots. If I run 
> "swapon" directly on the NFS file, things work fine, but it did mean 
> that I couldn't use the default "addswap" rc script to set up the swap 
> on my diskless system.
> I'm not sure whether it's supposed to work or not, but I haven't had 
> time to look into it yet. Just thought it might be another datapoint for 
> someone in the know to consider, just in case it is related.

It's a situation few people have probably tried.  If it persists on
6.0, please go through the same reporting procedure (debugging
traceback, file PR).


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-stable/attachments/20051115/2be99a71/attachment.bin

More information about the freebsd-stable mailing list