5.4, linux-pango and libfontconfig

Bruce Burden brucegb at realtime.net
Sun Nov 13 21:39:20 PST 2005



   Hi gang,

       Okay, several weeks ago, I told portupgrade to upgrade
  everything. Then flashplugin stopped working, because it could
  not find libfontconfig.so.1.

        On thing leads to another, and I am trying to get things
  working again. The problem is that linux apps are not using
  the linux-libfontconfig shared library:

===>   linux-pango-1.2.1_3 depends on file: /compat/linux/usr/X11R6/lib/libXrender.so.1 -
found
===>   Generating temporary packing list
pango-1.2.1-3.i386.rpm
/compat/linux/usr/bin/pango-querymodules: error while loading shared libraries: /usr/X11R6
/lib/libfontconfig.so.1: ELF file OS ABI invalid
*** Error code 127

Stop in /usr/ports/x11-toolkits/linux-pango.
*** Error code 1

Stop in /usr/ports/x11-toolkits/linux-pango.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade92806.19 make -DFORCE
_PKG_REGISTER reinstall
--->  Restoring the old version
** Fix the installation problem and try again.

        I have tried:

put /usr/X11R6/lib

into /compat/linux/etc/ld.so.conf

and run:

/compat/linux/sbin/ldconfig

        to no avail. First, /usr/X11R6/lib was already in the
   ld.so.conf file. And ldconfig does not want to add a ld-elf.so.hints
   file, at least that I can tell.

        Suggstions? The linux base is 8.8, btw.

						Thanks,
							Bruce
-- 
------------------------------------------------------------------------
  "I like bad!"                         Bruce Burden    Austin, TX.
        - Thuganlitha
        The Power and the Prophet
        Robert Don Hughes



More information about the freebsd-stable mailing list