"solved": Re: can't mount root after upgrade to RELENG_6

David Syphers dsyphers at u.washington.edu
Sun Dec 25 16:39:47 PST 2005

On Sunday 25 December 2005 12:37 pm, David Syphers wrote:
> I'm trying to upgrade a July 27 RELENG_5 box to today's RELENG_6. I got
> through buildworld and make kernel, but upon rebooting I get dropped into a
> mountroot prompt. Choosing '?' there only shows fd0. It's trying to mount
> root from /dev/ad0s1a, which is correct. Booting in safe mode mounts root
> fine and gives me a fully usable system

Apparently booting in safe mode disables apic. I was looking for differences 
between my old 5.x kernel and the new one, and realized I left 'device apic' 
in my new kernel. Rebuilding without it makes everything work fine.

I just assumed apic would be safe because, well, it's in GENERIC... Turns out 
it's deadly to my system.

Thanks to the couple folks who tried to help with this, even on a holiday.


"What's the good of having mastery over
cosmic balance and knowing the secrets of
fate if you can't blow something up?"
-Terry Pratchett

More information about the freebsd-stable mailing list