Brief Report: Acer AS5002LMi notebook with FreeBSD

Garrett Wollman wollman at
Sat Dec 3 16:14:08 PST 2005

<<On Sat, 3 Dec 2005 11:36:28 +0000 (GMT), Robert Watson <rwatson at FreeBSD.ORG> said:

> Last week, I ordered byself a new notebook -- for reasons of price, stock, 
> features, etc, I went with the Lenovo z60t 2511.

Hmmm.  Last week, I ordered myself a new laptop -- for reasons of
price, availability, minimal Intel proprietary parts content, etc., I
went with the Acer Aspire 5002LMi.

> comes with a 14" display (1280x768 widescreen), 1.86GHz 
> Pentium M, 512M of memory, and a 60GB hard disk.

14-inch display (1024x768 normalscreen), 1.6-GHz Turion64, 512 Mbyte
of memory, and an 80-Gbyte hard disk.

> It also has hardware fingerprint scanner, bluetooth, SD card reader,
> broadcom gig-e, firewire, atheros 802.11 chipset, and various other
> neat things.

Mine doesn't have any of those neat things.  The chipset is SiS,
including Fast Ethernet (no Gig), USB2, and dual-screen video.  One
CardBus slot, no legacy ports (but the internal keyboard and touchpad
are PS/2, not USB).  All of the other Acer non-Centrino laptops I had
been able to examine came with Atheros wireless, but this one is
Broadcom.  I haven't tried Project Evil yet; since I had a Cardbus
wireless card available I used that.  There are other builds of this
platform that include Bluetooth support; mine has a button on the
front panel for it but lacks the interface.

> After chatting with Bjoern Zeeb <bz>, I concluded that I would leave XP on 
> the notebook, as well as the IBM maintenance partition.  The advantage to 
> keeping these around is that it makes it possible to pick up useful things 
> like BIOS updates, and possibly makes getting support easier when things 
> go horribly wrong (hasn't happened yet).

Sometimes I need to test/run Windows software, so there was no
question for me.  The machine shipped with XP Pro.  Acer was
considerate and partitioned the drive into two logical volumes (repeat
after me, "C: is for Crap and D: is for Data").  This machine required
a BIOS upgrade in order to fix a problem with the Synaptics touchpad.
I was able to tell Windows that I really didn't want the extra
partition, and then I was able to install 6.0 over the network on the
back half of the disk.  The whole install (including KDE) took less
than an hour and was probably the smoothest install I've ever done
using sysinstall.

> (2) 6.8.2 used the VESA video mode 1024x768.

I had interesting video issues with this laptop.  The video mode used
by Windows for 1024x768 made the projector I was testing with deeply
unhappy.  X worked just fine standalone, but if I started it with the
projector connected, it used a weird 1024x576 wide-screen mode which
neither I nor the projector cared much for.  After overriding X's idea
of "Generic VGA Monitor" sync rates, I was able to get 1024x768 to
work on both the LCD and the projector.

> (4) When I loaded the if_ath driver to use the wireless, I got an NMI
>      and panic.

Didn't happen for me.  I did find that it mattered whether I
specifically assigned an SSID to the wireless; when I did not do so, I
was unable to communicate with my infrastructure network.  I won't
have time to debug this before I leave for San Diego on Monday.

> At the end of the day, I have most things working with this notebook 
> except for the following:

> - I don't yet have the sound driver attaching.

This card has an SiS 7012, which attaches to the snd_ich driver.  On
attach it reports "Unknown AC97 Codec (id = 0x414c4770)" but this does
not seem to cause a failure.  From my research this seems to be an
Avance Logic ALC203; I just addded it to ac97.c but haven't had a
chance to test it yet.

> - Suspend/resume was pretty sad, I don't advise trying it.  I may get a
>    chance to investigate this more while on travel over the next few weeks.

ACPI seems to be somewhat broken on this machine, even after updating
to the latest BIOS.  The CPU-state information looks bogus (and
telling the kernel to use C3 is asking for trouble).  Suspend doesn't.
There's an error in the \\_SB_.BAT1._BST method so it can't get the
battery status.  Dump available on request.


More information about the freebsd-stable mailing list