4.8->4.9 => installworld error :touch not found

Dorin H bj93542 at yahoo.com
Sat Jan 10 17:53:00 PST 2004

Hi there,
 I am trying to update an up-to-date 4.8 to 4.9. and I
am getting the (classic) error:
  "touch not found"
while doing the make installworld.
 Yes, I know it was discused a couple of times, but
the date seems correct (as reported by date(1) ).

#cvsup to RELENG_9 (01/10/2004, morning EST)
	as from UPDATING (4.8->4.9):
#make buildworld (0k)
#make buildkernel KERNCONF=MYKERN (0k)
#make installkernel KERNCONF=MYKERN (0k)
reboot in single mode as
  boot -s
  fsck -p
  mount -u /
  mount -a -t ufs
  swapon -a
  adjkentz -i (0k)
make installworld 
-> fail with error:

>>> Installing everything..
cd /usr/src; make -f Makefile.inc1 install
===> share/info
===> include
creating osreldate.h from newvers.sh
setvar PARAMFILE /usr/src/include/../sys/sys/param.h; 
. /usr/src/include/../sys/conf/newvers.sh;            
           echo "$COPYRIGHT
" > osreldate.h;                         echo "#ifdef
_KERNEL" >> osreldate.h;                   echo
'#error "osreldate.h must not be us
ed in the kernel, use sys/param.h"' >> osreldate.h; 
echo "#else" >> osreldate.h;                          
     echo \#'undef __FreeBSD_
version' >> osreldate.h;         echo \#'define
__FreeBSD_version' $RELDATE >> osreldate.h;  echo
"#endif" >> osreldate.h
touch: not found
*** Error code 127

Stop in /usr/src/include.
*** Error code 1

I have checked the date:
# date
Sat Jan 10 20:44:50 EST 2004 (correct)

I tried again by rebooting in single mode and
eliminating "adjkerntz -i" command.  I got the same
error (the date is again correct).

I tried to trick it and modify newvers.sh to have the
full path for touch : /usr/bin/touch.
I got the error:

>>> Installing everything..
cd /usr/src; make -f Makefile.inc1 install
===> share/info
===> include
install -C -o root -g wheel -m 444  a.out.h ar.h
assert.h bitstring.h complex.h ctype.h db.h dirent.h
disktab.h dlfcn.h elf.h elf-hints.h
 err.h fnmatch.h fstab.h fts.h glob.h grp.h strhash.h
histedit.h ieeefp.h ifaddrs.h iso646.h langinfo.h
libgen.h limits.h link.h locale.h
 malloc.h memory.h mpool.h ndbm.h netdb.h nl_types.h
nlist.h objformat.h paths.h pthread.h pthread_np.h
pwd.h ranlib.h readpassphrase.h r
egex.h regexp.h resolv.h rune.h runetype.h search.h
setjmp.h sgtty.h signal.h stab.h stdbool.h stddef.h
stdio.h stdlib.h string.h stringl
ist.h strings.h struct.h sysexits.h tar.h time.h
timers.h ttyent.h unistd.h utime.h utmp.h vis.h
wchar.h wctype.h osreldate.h /usr/includ
install:No such file or directory
*** Error code 1

Stop in /usr/src/include.
*** Error code 1

I am missing someting here but I can't figure it out. 
Please, give me some "light" :)


PS. For now I am working with the new kernel on the
old world (no ps and co.) until I figure it out.
Please let me know of any additional info required.


Do you Yahoo!?
Yahoo! Hotjobs: Enter the "Signing Bonus" Sweepstakes

More information about the freebsd-stable mailing list