SMP/HTT problems with 4.10-BETA

Gregory Neil Shapiro gshapiro at
Wed Apr 14 00:00:32 PDT 2004

> I almost wonder if you have a buggy set og CPUs.  Have you tried
> updating the BIOS?  Often times updated BIOSes have updated uCode
> patches for the CPU.

I tried it on my HTT system (Dell PowerEdge 400SC, up-to-date BIOS) as
well and had similar results.  Setting machdep.hlt_logical_cpus to 0 on
a running system ended up with various processes crashing over the next
12 hours.  The system has been running absolutely fine before doing this
and after rebooting to get back to the default setup.

It is quite possible that it is my own fault if machdep.hlt_logical_cpus
should only be set during boot as a loader tunable but that isn't the
way I read the UPDATING entry.

Here are the details:

Time line:

Apr  8 21:24    sysctl machdep.hlt_logical_cpus=0 

Apr  9 00:22:44 horsey /kernel: pid 130 (named), uid 53: exited on signal 6
Apr  9 00:23:32 horsey /kernel: pid 30932 (perl), uid 103: exited on signal 11
Apr  9 00:34:41 horsey /kernel: pid 31223 (perl), uid 103: exited on signal 11
Apr  9 00:46:41 horsey /kernel: pid 31389 (perl), uid 103: exited on signal 11
Apr  9 01:02:57 horsey /kernel: pid 31645 (perl), uid 103: exited on signal 11
Apr  9 01:14:50 horsey /kernel: pid 31815 (perl), uid 103: exited on signal 11
Apr  9 02:10:40 horsey /kernel: pid 32879 (perl), uid 103: exited on signal 11
Apr  9 03:06:33 horsey /kernel: pid 34102 (cvsup), uid 63: exited on signal 6 (core dumped)
Apr  9 04:38:53 horsey /kernel: pid 36119 (perl), uid 103: exited on signal 11
Apr  9 04:58:21 horsey /kernel: pid 36420 (sendmail:8.13.0.), uid 0: exited on signal 12
Apr  9 05:16:14 horsey /kernel: pid 36952 (perl), uid 103: exited on signal 11
Apr  9 05:58:48 horsey /kernel: pid 37908 (perl), uid 103: exited on signal 11
Apr  9 06:59:59 horsey /kernel: pid 39287 (perl), uid 103: exited on signal 11
Apr  9 09:35:51 horsey /kernel: pid 43877 (perl), uid 103: exited on signal 11
Apr  9 10:42:27 horsey /kernel: pid 47579 (perl), uid 103: exited on signal 11
Apr  9 11:23:34 horsey /kernel: pid 41658 (named), uid 53: exited on signal 6
Apr  9 11:45:38 horsey /kernel: pid 49470 (sendmail:8.13.0.), uid 0: exited on signal 12
Apr  9 11:55:36 horsey /kernel: pid 49854 (perl), uid 103: exited on signal 11
Apr  9 12:09:00 horsey /kernel: pid 50248 (perl), uid 103: exited on signal 11
Apr  9 12:16:30 horsey /kernel: pid 50453 (perl), uid 103: exited on signal 11
Apr  9 12:23:43 horsey /kernel: pid 50632 (perl), uid 103: exited on signal 11

Apr  9 12:55:22 reboot


Copyright (c) 1992-2003 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD 4.10-BETA #17: Sat Apr 10 12:24:44 PDT 2004
    gshapiro at
Timecounter "i8254"  frequency 1193182 Hz
CPU: Intel(R) Pentium(R) 4 CPU 2.40GHz (2394.01-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0xf29  Stepping = 9
  Hyperthreading: 2 logical CPUs
real memory  = 1073168384 (1048016K bytes)
avail memory = 1040097280 (1015720K bytes)
Changing APIC ID for IO APIC #0 from 0 to 2 on chip
Programming 24 pins in IOAPIC #0
IOAPIC #0 intpin 2 -> irq 0
FreeBSD/SMP: Multiprocessor motherboard: 2 CPUs
 cpu0 (BSP): apic id:  0, version: 0x00050014, at 0xfee00000
 cpu1 (AP):  apic id:  1, version: 0x00050014, at 0xfee00000
 io0 (APIC): apic id:  2, version: 0x00178020, at 0xfec00000
Pentium 4 TCC support enabled, current performance 100%
Preloaded elf kernel "kernel" at 0xc0461000.
Warning: Pentium 4 CPU: PSE disabled
Pentium Pro MTRR support enabled
Using $PIR table, 8 entries at 0xc00feae0
apm0: <APM BIOS> on motherboard
apm0: found APM BIOS v1.2, connected at v1.2
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcib0: <Host to PCI bridge> on motherboard
IOAPIC #0 intpin 16 -> irq 2
IOAPIC #0 intpin 19 -> irq 13
IOAPIC #0 intpin 18 -> irq 16
IOAPIC #0 intpin 23 -> irq 17
IOAPIC #0 intpin 17 -> irq 18
pci0: <PCI bus> on pcib0
pcib1: <PCI to PCI bridge (vendor=8086 device=2579)> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
uhci0: <Intel 82801EB (ICH5) USB controller USB-A> port 0xff80-0xff9f irq 2 at device 29.0 on pci0
usb0: <Intel 82801EB (ICH5) USB controller USB-A> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhub1: Atmel UHB124 hub, class 9/0, rev 1.00/1.00, addr 2
uhub1: 4 ports with 4 removable, bus powered
umass0: SanDisk Corporation ImageMate CompactFlash USB, rev 1.10/0.09, addr 3
umass0: Get Max Lun not supported (STALLED)
umass1: Alcor Micro Mass Storage Device, rev 1.10/1.00, addr 4
umass1: Get Max Lun not supported (STALLED)
uhci1: <Intel 82801EB (ICH5) USB controller USB-B> port 0xff60-0xff7f irq 13 at device 29.1 on pci0
usb1: <Intel 82801EB (ICH5) USB controller USB-B> on uhci1
usb1: USB revision 1.0
uhub2: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
uhci2: <Intel 82801EB (ICH5) USB controller USB-C> port 0xff40-0xff5f irq 16 at device 29.2 on pci0
usb2: <Intel 82801EB (ICH5) USB controller USB-C> on uhci2
usb2: USB revision 1.0
uhub3: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub3: 2 ports with 2 removable, self powered
uhci3: <Intel 82801EB (ICH5) USB controller USB-D> port 0xff20-0xff3f irq 2 at device 29.3 on pci0
usb3: <Intel 82801EB (ICH5) USB controller USB-D> on uhci3
usb3: USB revision 1.0
uhub4: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub4: 2 ports with 2 removable, self powered
pci0: <USB controller> at 29.7 irq 17
pcib2: <Intel 82801BA/BAM (ICH2) Hub to PCI bridge> at device 30.0 on pci0
IOAPIC #0 intpin 21 -> irq 19
IOAPIC #0 intpin 22 -> irq 20
pci2: <PCI bus> on pcib2
pci2: <ATI Mach64-GR graphics accelerator> at 0.0 irq 19
fwohci0: <Lucent FW322/323> mem 0xfe9df000-0xfe9dffff irq 20 at device 1.0 on pci2
fwohci0: OHCI version 1.0 (ROM=1)
fwohci0: No. of Isochronous channel is 8.
fwohci0: EUI64 00:30:dd:80:00:50:fb:f0
fwohci0: Phy 1394a available S400, 3 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 02:30:dd:50:fb:f0
sbp0: <SBP-2/SCSI over FireWire> on firewire0
sbp_targ0: <SBP-2/SCSI over FireWire target mode> on firewire0
fwohci0: Initiate bus reset
fwohci0: node_id=0xc800ffc0, gen=1, CYCLEMASTER mode
firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
firewire0: bus manager 0 (me)
em0: <Intel(R) PRO/1000 Network Connection, Version - 1.7.25> port 0xddc0-0xddff mem 0xfe9e0000-0xfe9fffff irq 16 at device 12.0 on pci2
em0:  Speed:N/A  Duplex:N/A
isab0: <PCI to ISA bridge (vendor=8086 device=24d0)> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH5 ATA100 controller> port 0xffa0-0xffaf,0x374-0x377,0x170-0x177,0x3f4-0x3f7,0x1f0-0x1f7 mem 0xfebffc00-0xfebfffff irq 16 at device 31.1 on pci0
ata0: at 0x1f0 irq 14 on atapci0
ata1: at 0x170 irq 15 on atapci0
atapci1: <Intel ICH5 SATA150 controller> port 0xfea0-0xfeaf,0xfe30-0xfe33,0xfe20-0xfe27,0xfe10-0xfe13,0xfe00-0xfe07 irq 16 at device 31.2 on pci0
ata2: at 0xfe00 on atapci1
ata3: at 0xfe20 on atapci1
ichsmb0: <Intel 82801EB (ICH5) SMBus controller> port 0xeda0-0xedbf irq 18 at device 31.3 on pci0
smbus0: <System Management Bus> on ichsmb0
smb0: <SMBus general purpose I/O> on smbus0
pcm0: <Intel ICH5 (82801EB)> port 0xedc0-0xedff,0xee00-0xeeff mem 0xfebff900-0xfebff9ff,0xfebffa00-0xfebffbff irq 18 at device 31.5 on pci0
pcm0: <Analog Devices AD1980 AC97 Codec>
orm0: <Option ROMs> at iomem 0xc0000-0xc7fff,0xc8000-0xc97ff,0xc9800-0xcbfff on isa0
pmtimer0 on isa0
fdc0: <NEC 72065B or clone> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse, device ID 3
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
sc0: <System console> on isa0
sc0: VGA <16 virtual consoles, flags=0x200>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
sio1 at port 0x2f8-0x2ff irq 3 on isa0
sio1: type 16550A
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/8 bytes threshold
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
pca0 at port 0x40 on isa0
ipfw2 initialized, divert enabled, rule-based forwarding enabled, default to deny, logging unlimited
IPv6 packet filtering initialized, unlimited logging
IPsec: Initialized Security Association Processing.
SMP: AP CPU #1 Launched!
ad0: 76319MB <WDC WD800BB-40BSA0> [155061/16/63] at ata0-master UDMA66
sbp_targ_action1: unknown function 2305
sbp_targ_action1: unknown function 2305
sbp_targ_action1: unknown function 2305
sbp_targ_action1: unknown function 2305
sbp_targ_action1: unknown function 2305
sbp_targ_action1: unknown function 2305
sbp_targ_action1: unknown function 2305
Mounting root from ufs:/dev/ad0s1a
cd0 at ata1 bus 0 target 0 lun 0
cd0: <Lite-On LTN486S 48x Max YDS6> Removable CD-ROM SCSI-0 device 
cd0: 16.000MB/s transfers
cd0: Attempt to query device size failed: NOT READY, Medium not present
cd1 at ata1 bus 0 target 1 lun 0
cd1: <CENDYNE_ 481648AX 150F> Removable CD-ROM SCSI-0 device 
cd1: 16.000MB/s transfers
cd1: Attempt to query device size failed: NOT READY, Medium not present
da0 at umass-sim0 bus 0 target 0 lun 0
da0: <SanDisk ImageMate II 1.30> Removable Direct Access SCSI-2 device 
da0: 650KB/s transfers
da0: Attempt to query device size failed: NOT READY, Medium not present
da1 at umass-sim0 bus 0 target 1 lun 0
da1: <Generic USB SD Reader 2.00> Removable Direct Access SCSI-0 device 
da1: 650KB/s transfers
da1: Attempt to query device size failed: NOT READY, Medium not present

Kernel config:

# Preamble
machine		i386			# Architecture (do not change)
cpu		I686_CPU		# Pentium Pro, Pentium II
ident		HORSEY			# Identification
maxusers	0			# Sets kernel table sizes automatically

# Kernel options
options		APIC_IO			# Symmetric (APIC) I/O
options		CD9660			# ISO 9660 filesystem
options		COMPAT_43		# Compatible with BSD 4.3 [KEEP THIS!]
options		CPU_ENABLE_SSE		# Enables SSE/MMX2 instructions support
options		CPU_ENABLE_TCC		# Pentium 4 Thermal Control Circuitry
options		DDB			# Enable the kernel debugger
options		FFS			# Berkeley Fast Filesystem
options		FFS_ROOT		# Use FFS for root partition
options		ICMP_BANDLIM		# Enable ICMP bandwidth limiting
options		INCLUDE_CONFIG_FILE	# Include this file in kernel
options		INET			# InterNETworking
options		INET6			# IPv6 communications protocols
options		IPDIVERT		# Divert IP sockets (ifpw divert)
options		IPFIREWALL		# IP firewall
options		IPFIREWALL_FORWARD	# Transparent proxy support
options		IPFIREWALL_VERBOSE	# Print info about dropped packets
options		IPFW2			# ipfw version 2
options		IPSEC			# IP security
options		IPSEC_ESP		# IP security (crypto; define w/ IPSEC)
options		IPSEC_DEBUG		# Debug for IP security
options		IPSTEALTH		# Support for stealth forwarding
options		IPV6FIREWALL		# Firewall for IPv6
options		IPV6FIREWALL_VERBOSE	# Print info about dropped packets
options		KBD_INSTALL_CDEV	# Install a CDEV entry in /dev
options		KTRACE			# Kernel tracing
options		NFS			# Network Filesystem
options		P1003_1B		# P1003_1B: Infrastructure
options		PERFMON			# Pentium/Pentium Pro perf counters
options		PROCFS			# Process filesystem
options		QUOTA			# Enable disk quotas
options		SCSI_DELAY=8000		# Be pessimistic about Joe SCSI device
options		SMP			# Symmetric MultiProcessor Kernel
options		SOFTUPDATES		# Kirk's Soft Updates
options		SYSVMSG			# System V message queues
options		SYSVSEM			# System V semaphores
options		SYSVSHM			# System V shared memory
options		TCP_DROP_SYNFIN		# Drop TCP packets with SYN+FIN
options		UFS_DIRHASH		# Directory hashing
options		USERCONFIG		# boot -c editor
options		USER_LDT		# Allow user-level control of i386 ldt
options		VISUAL_USERCONFIG	# Visual boot -c editor
options		_KPOSIX_VERSION=199309L	# Version kernel is built for

# Buses
device		isa		# ISA bus
device		pci		# PCI bus

# Floppy
device		fdc0	at isa? port IO_FD1 irq 6 drq 2
device		fd0	at fdc0 drive 0

device		ata
device		atadisk		# ATA disk drives
device		atapicam	# ATA CAM interface

# SCSI peripherals
device		scbus		# SCSI bus (required)
device		da		# Direct Access (disks)
device		cd		# CD
device		pass		# Passthrough device (direct SCSI access)

# AT keyboard
device		atkbdc0	at isa? port IO_KBD
device		atkbd0	at atkbdc? irq 1 flags 0x1

# PS/2 mouse
device		psm0	at atkbdc? irq 12

# VGA port
device		vga0	at isa?

# syscons is the default console driver, resembling an SCO console
device		sc0	at isa?

# Numeric Processing eXtension (mandatory, don't remove)
device		npx0	at nexus? port IO_NPX irq 13

# Advanced power management
device		apm0	at nexus? flags 0x20

# Serial ports
device		sio0	at isa? port IO_COM1 flags 0x10 irq 4
device		sio1	at isa? port IO_COM2 irq 3

# Parallel port
device		ppc0	at isa? irq 7
device		ppbus		# Parallel port bus (required)
device		lpt		# Printer
device		ppi		# Parallel port interface device

# Ethernet
device		em		# Intel Pro/1000 (82542,82543,82544,82540)

# Sound
device		pcm

# SMB bus
device		smbus		# Bus support, required for smb below.
device		ichsmb		# Intel ICH SMBus controller chips
device		smb		# Standard IO through /dev/smb*

# PC Speaker
device		pca0	at isa? port IO_TIMER1

# USB support
device		uhci		# UHCI PCI->USB interface
device		ohci		# OHCI PCI->USB interface
device		usb		# USB Bus (required)
device		ugen		# Generic
device		uhid		# "Human Interface Devices"
device		ukbd		# Keyboard
device		ulpt		# Printer
device		umass		# Disks/Mass storage - Requires scbus and da
device		ums		# Mouse
device		uscanner	# USB scanners
device		ucom		# USB serial
device		uplcom		# USB serial
device		uvscom		# USB serial
device		uftdi		# USB serial
device		uvisor		# USB Visor

# FireWire support
device		firewire	# FireWire bus code
device		sbp		# SCSI over FireWire (Requires scbus and da)
device		sbp_targ	# SBP-2 Target mode  (Requires scbus and targ)
device		fwe		# Ethernet over FireWire (non-standard!)

# Pseudo devices
pseudo-device	bpf		# Berkeley Packet Filter (BPF)
pseudo-device	ether		# Generic Ethernet
pseudo-device	gif		# IPv6 and IPv4 tunneling
pseudo-device	gzip		# Exec gzipped a.out's
pseudo-device	loop		# Network loopback device
pseudo-device	pty		# Pseudo ttys
pseudo-device	snp	3	# Snoop device - to look at pty/vty/etc..
pseudo-device	speaker		# Play IBM BASIC-style noises out your speaker
pseudo-device	splash		# Splash screen at start up!
pseudo-device	stf		# 6to4 IPv6 over IPv4 encapsulation
pseudo-device	tun		# Tunnel driver (ppp(8), nos-tun(8))
pseudo-device	vn		# Vnode driver (turns a file into a device)

More information about the freebsd-stable mailing list