GLX Problems

Igor Pokrovsky tiamat at
Wed Nov 19 19:50:36 PST 2003

On Wed, Nov 19, 2003 at 07:53:36PM -0500, Andrew Morritt wrote:
> I have been trying to use several OpenGl games, but it always gives me a 
> GLX error. /usr/X11R6/lib/modules/extensions/ does not exist. I 
> call GLX from my XFConfig file. In /var/logs/XFree86.0.log, it says 
> Module not found. I have Mesa3 installed, I have rebuild it several 
> times (with portupgrade) and I have tried rebuilding X. I am using 
> FreeBSD 4.9. I was working on this with a guy in the #FreeBSDHelp 
> channel, and he eventually told me to take this to the stable mailing 
> list. I have tried copying libglx.a to cd / && ls -alR | grep 
> glx turns up no library files. Anyone know what the problem might be?

I suppose you are running XFree86 4.x? In this case GLX code is in main
XFree distribution and separate Mesa port is used only to get GLUT installed.
So you probably can try to reinstall XFree from ports.


God made the world in six days, and was arrested on the seventh.

More information about the freebsd-stable mailing list