Shared object not found - library / buildworld issue

Alejandro Ayala churry at
Sat Jun 14 08:40:06 PDT 2003

I muck my system badly now I can´t even do "vi" or anything really. It won't 
boot either, only to single mode.  I was the one who tried to upgrade from 
freebsd 4.7-release to 5.1-release.  Got the source through cvs did a make 
buildworld and it failed.  tried it a couples of times again and somehow 
blew my libraries (it happen right after i went to 
/usr/src/lib/compat/compat4x.i386 and did a make all install, of course it 
failed)and now is saying

/usr/libexec/ Shared object <library here> not found. Anytime i 
try to run a prog, like I said even vi is giving me that error.  Seems to me 
like all libraries are gone since i try to do a make all install in the 
compat directory.  I know I'm a newbie, but I did read the src/UPDATING 
before doing a make buildworld and couldnt find out anything that explain 
why the errors were happening.

The first time the errors were about the libpthread, then the error happen 
during the geting an up-to-date make. And now is the library issue.  Is 
there a way to rebuild the libraries? from single mode.


Tired of spam? Get advanced junk mail protection with MSN 8.

More information about the freebsd-stable mailing list