hostname cores

Southo keith at
Mon Jun 9 12:20:51 PDT 2003

Greetings Listmembers,

Any thoughts on why I would get segmentation faults every time I run
hostname(8)? I get the same error when using 'su'. I suppose this is because
the system is looking for the hostname or something related. Whenever I run
the hostname or su commands I get a segmentation fault error and a core file
(hostname.core) in the current dir. 

I've tried debugging, totally not knowing what I'm doing, and managed to
produce this hoping it will help one of the gurus on the list help me out.

# gdb -c hostname.core
GNU gdb 4.18 (FreeBSD)
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-unknown-freebsd".
Core was generated by `hostname'.
Program terminated with signal 11, Segmentation fault.
#0  0x7f00 in ?? ()
(gdb) bt
#0  0x7f00 in ?? ()
#1  0x8048127 in ?? ()
Cannot access memory at address 0x80480b6.

I've been searching the net for answers. I've been to the signal 11 faq's
page and will try swapping out the ram in an attempt to fix.

I thought maybe there was a problem with the cvsup and make world I did on
this machine so I tried to update again. Now I cant finish make buildworld
due to errors in the buildprocess, will post in another thread due to lack
of information the moment. I was also wondering if it's possible to just
rebuild the hostname binary if that would fix this.

# uname -a
FreeBSD 4.8-STABLE FreeBSD 4.8-STABLE #0: Mon May 19
17:11:53 PDT 2003

TIA for any pointers to fixing this problem

More information about the freebsd-stable mailing list