Pioneer DVD-120s probe problem

Jason Andresen jandrese at
Tue Apr 22 06:23:43 PDT 2003

Hello, I'm building a new system for a friend and I bought a
Pioneer DVD-120s drive for him because it was a newer version of the 
drive I use (DVD-116) and my friend uses (DVD-106s) with FreeBSD.  The 
problem is that FreeBSD cannot probe the drive for some reason.  I've 
tried twiddling the ATAPI_DMA bit, rescanned the drive, and toyed with 
the cable, but nothing seems to work.

The BIOS can see the drive, in fact I can boot FreeBSD using the 
El-Torrito boot sector on the drive, but I cannot use the CD as the 
distribution in the installer.

FreeBSD 4.8-RELEASE boots all the way up to the point where it lists the 
ATA devices, then gets in an infinate loop with ATAPI Timeouts.

FreeBSD 5-CURRENT does not get in an infinate loop, but returns the 
following error on boot:

ata1-master: timeout waiting for interrupt
ata1-master: ATAPI identify failed

Using the following hardware:
atapci0: <VIA 8233A UDMA133 controller> port 0xd000-0xd00f at device 
17.1 on pci0

The same problem occured with this hardware:
atapci0: <VIA 8233 ATA100 controller> port 0xe000-0xe00f at device 17.1 
on pci0

Windows XP has no trouble detecting or using this drive.  I have tried 
setting the region on the drive and that did not seem to help.

Does anybody know what the problem is here?

   \  |_ _|__ __|_ \ __| Jason Andresen        jandrese at
  |\/ |  |    |    / _|  Network and Distributed Systems Engineer
_|  _|___|  _| _|_\___| Office: 703-883-7755

More information about the freebsd-stable mailing list