Gnome port acting weird?

Joe Marcus Clarke marcus at marcuscom.com
Mon Apr 14 06:26:55 PDT 2003


On Mon, 2003-04-14 at 08:31, Michael Sig Birkmose wrote:
> Hi!
> 
> Today I tried installing gnome2 using ports on a fresh FreeBSD 4.8 box.
> 
> After some time the build existed with some error in the gstreamer-plugins
> port (something ala "Ignoring previously applied (or reversed) patch.")
> I had just cvsuped before typing make so I dont think that was the problem?
> Anyhow I ended up deleting the /usr/ports/multimedia/gstreamer-plugins
> folder and cvs uping again, getting a fresh folder. Then I make install'ed
> this port and afterwards make install'ed the gnome2 port again - this time
> with no prob.
> 
> So more or less what I did was:
> (cvsup stuff)
> cd /usr/ports/x11/gnome2
> make install clean
> (error)
> rm -rf /usr/ports/multimedia/gstreamer-plugins
> (cvsup stuff)
> cd /usr/ports/multimedia/gstreamer-plugins
> make install clean
> cd /usr/ports/x11/gnome2
> make install clean
> 
> and then it worked.
> I just wonder what went wrong?
> Anyone had similar problems?

I had another look at this, and it looks like the ports tarball
installed from download (e.g. the 4.8-RELEASE CD) has a corrupted patch
(probably due to the long name of the patch).  When you do a cvsup, the
correctly named patch is downloaded.  With both of them present, you get
this behavior.  Simply cd to
/usr/ports/multimedia/gstreamer-plugins/files, and remove the patch with
the truncated name.

Joe

> 
> _______________________________________________
> freebsd-stable at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-stable
> To unsubscribe, send any mail to "freebsd-stable-unsubscribe at freebsd.org"
-- 
PGP Key : http://www.marcuscom.com/pgp.asc


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: This is a digitally signed message part
Url : http://lists.freebsd.org/pipermail/freebsd-stable/attachments/20030414/7a453996/attachment.bin


More information about the freebsd-stable mailing list