QLogic 2340 isp target mode

Brad Waite lists at wcubed.net
Tue Nov 30 20:40:15 UTC 2010

Thanks Matthew,

I removed all the isp.0 hints, but it doesn't seem to affect anything.

Oddly (at least to me), when I remove the isp_2300_load from loader.conf
I get the following in dmesg:

isp0: target notify code 0x100b

scsi_target still doesn't work, although I'm still not sure what to use
for the device:target:LUN option.

I had scoured -scsi and thought I'd come across everything related to
isp target mode, but I just found the following post from last month:


Penta had the same version and HBAs with the following config:

options               ISP_TARGET_MODE
options               ISP_DEFAULT_ROLES=1


Is it correct to assume that the ISP_TARGET_MODE option didn't actually
enable target mode because it wasn't set to 1 but that the hint did?

Thanks again for the help. I'll write up a How-To if I get this working
and hopefully cut down on redundant questions on the list.

On 11/30/2010 10:25 AM, Matthew Jacob wrote:
> the options
> options         ISP_TARGET_MODE=1
> options         ISP_DEFAULT_ROLES=1
> do what you want. Remove the hint.
> On 11/30/2010 10:18 AM, Brad Waite wrote:
>> Hi there, SCSI wizards!
>> I'm working on getting my QLogic 2340 under 8.1 to show a target to
>> VMware ESXi w/another 2340 in point-to-point mode. A single dual-optical
>> cable is connected directly to the two HBAs - no switches or other devices.
>> `scsi_target -d 0:0:0 /usr/local/share/vol` returns this before hanging:
>> scsi_target: volume_size: 512 bytes x 20480 sectors
>> scsi_target: aio support tested ok
>> scsi_target: TARGIOCENABLE: Operation not supported
>> scsi_target: cleanup called
>> ...and in dmesg:
>> controller does not support target mode
>> Is /usr/share/examples/scsi_target the "right" thing to use? How do you
>> specify which device to present a target? I assume it's the bus/target
>> ID, but how do I find it? Nothing's showing up in `camcontrol devlist`
>> for the HBA and `camcontrol start isp0` reports this:
>> camcontrol: cam_lookup_pass: CAMGETPASSTHRU ioctl failed
>> cam_lookup_pass: No such file or directory
>> cam_lookup_pass: either the pass driver isn't in your kernel
>> cam_lookup_pass: or isp0 doesn't exist
>> What am I missing?
>> Thanks.
>> -bmw
>> kernel config:
>> device          scbus           # SCSI bus (required for SCSI)
>> device          pass            # Passthrough device (direct SCSI access)
>> device          isp             # Qlogic family
>> device          targ            #SCSI Target Mode Code
>> device          targbh          #SCSI Target Mode Blackhole Device
>> options         VFS_AIO
>> options         ISP_TARGET_MODE=1
>> options         ISP_DEFAULT_ROLES=1
>> /boot/loader.conf:
>> isp_2300_load="YES"
>> /boot/device.hints:
>> hint.isp.0.role="target" (should this be "target" or "1"?)
>> hint.isp.0.iid="0"
>> dmesg:
>> isp_2300: registered firmware<isp_2300>
>> isp0:<Qlogic ISP 2312 PCI FC-AL Adapter>  port 0x7000-0x70ff mem
>> 0xfc200000-0xfc200fff irq 28 at device 2.0 on pci2
>> isp0: [ITHREAD]
>> _______________________________________________

More information about the freebsd-scsi mailing list