Incorrect geometry with 750G ciss array

Ulf Zimmermann ulf at
Sat Apr 26 00:56:22 UTC 2008

On Thu, Apr 24, 2008 at 12:55:37PM -0500, Kevin Day wrote:
> On Apr 24, 2008, at 3:18 AM, Ivan Voras wrote:
> >Kevin Day wrote:
> >>ciss0: <HP Smart Array E200> port 0xe800-0xe8ff mem
> >>0xdef80000-0xdeffffff,0xdef78000-0xdef7ffff irq 35 at device 8.0 on  
> >>pci5
> >>ciss0: [ITHREAD]
> >>da0: 762977MB (1562578608 512 byte sectors: 255H 32S/T 65535C)
> >>
> >>Sysinstall's partition editor comes up with 97266/255/63, but it
> >>re-complains that it's incorrect after every single keypress in it.  
> >>If I
> >>push ahead anyway, I can't boot (hang after pressing F1 at the  
> >>loader).
> >>
> >I don't know about that specific model, but I had similar symptoms  
> >with
> >several Proliants, some of which had the same ciss card, some not,  
> >which
> >are solved by using a different boot loader (i.e. the partitioning is
> >fine, just the boot loader isn't). Try sysutils/extipl, search the
> >mailing list archives for details.
> That was exactly it, but I solved the problem a slightly different  
> way. Instead of selecting BootMgr after partitioning, I just installed  
> the standard MBR. That seems to find the partition just fine, and the  
> system boots okay.
> I'll have to do some more digging to see what BootMgr's problem is.
> Thanks!
> -- Kevin

The other thing I have done with HP servers is just make a small system
disk, i.e. enough for root and maybe swap, then make another raid (Logical
disk or LD in SmartArray terms) for the rest of the system.

Regards, Ulf.

Ulf Zimmermann, 1525 Pacific Ave., Alameda, CA-94501, #: 510-865-0204
You can find my resume at:

More information about the freebsd-scsi mailing list