Rake dependency problem for Ruby 1.9.1

Stanislav Sedov stas at FreeBSD.org
Wed Feb 3 23:50:03 UTC 2010


On Wed, 3 Feb 2010 19:08:47 +0800
Jyun-Yan You <crabtw at gmail.com> mentioned:

> On Wed, Feb 3, 2010 at 6:18 PM, Stanislav Sedov <stas at freebsd.org> wrote:
> 
> > On Wed, 3 Feb 2010 18:05:50 +0800
> > Jyun-Yan You <crabtw at gmail.com> mentioned:
> >
> > > I got a problem when I tried to install some gems that depends rake.
> > >
> > > For example, www/rubygem-passenger, it needs devel/rubygem-rake but I
> > can't
> > > install it.
> > > It says that rake already included in Ruby 1.9.1.
> > >
> > > If I don't have rake in gem list, I can't install passenger
> > >
> > > How can I solve the problem?
> >
> > It shouldn't depend on it. rubygem-passenger has USE_RAKE=yes in Makefile,
> > and this knob adds dependency only if ruby 1.8 is used.  What command
> > do you use to install rubygem-passenger, and what the exact error message
> > is?
> >
> > --
> > Stanislav Sedov
> > ST4096-RIPE
> >
> 
> install rubygem-passenger:
> 
>     cd /usr/ports/www/rubygem-passenger
>     make RUBY_VER=1.9 install clean
> 
> error message:
> 
>     /usr/bin/env  /usr/local/bin/gem19 install -l --no-update-sources
> --no-ri --install-dir /usr/local/lib/ruby/gems/1.9
> /usr/ports/distfiles/rubygem/passenger-2.2.7.gem -- --build-args
>     ERROR:  Error installing
> /usr/ports/distfiles/rubygem/passenger-2.2.7.gem:
>             passenger requires rake (>= 0.8.1, runtime)
> 

Ok, I think there's a bug in rubygem-passenger, as we do have rake in ruby 1.9.
Maybe passenger doesn't support ruby 1.9 yet?


-- 
Stanislav Sedov
ST4096-RIPE
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 801 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-ruby/attachments/20100203/1cb64fea/attachment.pgp


More information about the freebsd-ruby mailing list