corrupted tar.gz archive - I lost my backups :)/:(

_ pancakeking79 at
Tue Feb 14 07:56:02 UTC 2012

2012/2/14, Adam Vande More <amvandemore at>:
> On Mon, Feb 13, 2012 at 7:56 PM, _ <pancakeking79 at> wrote:
>> Before making the move from 7.0 to 8.2, I ran a little script that did a
>> backup of selected files
>> and folders.
> I think it's IT tip #2 "You don't have a backup unless it's tested".  #1 is
> "Make a backup".

If I am not mistaken, I did test my backups and they worked fine.
After all, one of the four files that I have unpacks with no problems
so I don't see where things could have gone wrong.

> You could try archivers/gzrecover

After gzrecover and cpio, the process stops at the same point where
the tar(1) command stops. It simply doesn't make it beyond the
boundary where the file is corrupted.

> Good luck,
> --
> Adam Vande More

Here is what pax(1) gave me:

# pax -rzf su12292011.tar.gz
pax: Invalid header, starting valid header search.
gzip: data stream error
pax: End of archive volume 1 reached

ATTENTION! pax archive volume change required.
Ready for archive volume: 2
Input archive name or "." to quit pax.
Archive name > .
Quitting pax!

Nothing new here. It seems like pax simply invokes gzip(1) internally.

More information about the freebsd-questions mailing list