Access to Time Warner cable network

Jerry jerry at
Sun Apr 1 20:03:58 UTC 2012

On Sun, 01 Apr 2012 14:10:52 -0400
Fbsd8 articulated:

> Well here is the results of my attempts to connect to Time Warner
> cable network.
> After 4 calls to their call center which was in the Philippines where 
> all the people just read a scripted answer FAQ and only had the
> ability to remotely reset the modem. I finally requested to talk to
> the top support level in the USA. Finally got a tech support person
> who knew something about how their network was configured.
> Their modems at power up time run a script that is really a private
> LAN using 192.168.x.x to auto verify the cable modem mac address
> against a table of authorized accounts. At the conclusion the
> dhcp server issues a real routable ip address along with the
> routable 2 dns ip address.
> Now this long duration hand shake takes about 40 seconds and on a 
> windows system, windows keeps looping through the ip and dns acquire 
> code until it succeeds. Now on freebsd the ifconfig_fxp0="DHCP" seems
> to only cycle a single time and results in a "no carrier" status in
> the boot up msg log.
> After the Freebsd 8.2 boot process completed and I saw "no carrier" 
> status i issued "/etc/rc.d/netif restart" command which resulted in
> the same status. This is when I posted to the questions list for
> help. It was after the post that I had my conversation with the level
> 3 tech support guy and learned about the long hand shake process. I
> next tried issuing (ifconfig fxp0 up) after the freebsd boot process
> completed and to my surprise I had a public routable ip address. So I
> have to find a way during the boot process to give the
> ifconfig_fxp0="DHCP" statement in the /etc/rc.conf some delay time.
> But I think Freebsd 9.0 has an built in "up" process in its boot up
> process that may solve this problem.
> Another thing I learned from the level 3 support guy is that the
> cable modem has to be reset by unplugging it's power if I want to
> move the output cable to a different device, such as from the window
> box to the freebsd box or to a router.
> The bottom line is I have things working now and there was nothing
> wrong with either my window box or my freebsd box. Its just the Time
> Warner cable modem box and the non-standard way it's configured.

I have TW with an ARRIS model: TM602G/115 cable modem. I assume you
have a battery backup in your unit. If so, you have to remove the
battery before resetting the unit to insure it is actually cleared.

Have your tried accessing your modem via http? Usually or will work. Give your stations static addresses and see if
that makes life easier. By the way, while I don't know what modem you
have, mine can accommodate multiple units simultaneously. I don't know
why you have to reset it to use a different device. Are you connected
via Ethernet or wireless. Even Ethernet should allow a minimum of four
unique connections.

Jerry ♔

Disclaimer: off-list followups get on-list replies or get ignored.
Please do not ignore the Reply-To header.

More information about the freebsd-questions mailing list