/etc/rc.d/jail using new-style jail command?

Daniel Bye freebsd-questions at slightlystrange.org
Mon Jun 20 16:35:15 UTC 2011

On Mon, Jun 20, 2011 at 11:41:21AM -0400, Fbsd8 wrote:
> Daniel Bye wrote:
> >On Sun, Jun 19, 2011 at 10:16:05PM -0400, Fbsd8 wrote: 
> >>Give the qjail port a try. It has the ability to reference jails by name 
> >>and create jails without starting them. Though it does not use the 
> >>new-style jail command.
> >
> ><root at fbsd:/usr/ports/sysutils/qjail>
> >zsh/2 1002 # make install
> >===>  Installing for qjail-1.0
> >===>   Generating temporary packing list
> >===>  Checking if sysutils/qjail already installed
> >install:
> >/data/portbuild/usr/ports/sysutils/qjail/work/qjail-1.0/qjail-jail2: No 
> >such
> >/ file or directory
> >*** Error code 71
> >
> >Stop in /usr/ports/sysutils/qjail.
> >
> >
> >Any progress on getting the port fixed? I really like qjail, and find it
> >pretty intuitive, but the port hasn't worked properly since it was added to
> >the collection.
> >
> >Dan
> >
> Dan,
> qjail installs fine for me. You have something mis-configured
> on your system.
> /data/portbuild/ is invalid path which is not part of an normal install.

My system is set up just fine, thanks. My ports tree is located on a single
server, and shared via NFS.  To avoid hitting the rather slow disks in the
host machine, each client sets WRKDIRPREFIX so that ports build locally. 
This is fully supported by the ports system, and should not cause a
well-behaved port to break.[1] And indeed, this configuration has been
working flawlessly now for well over 6 years, and it is not the source of
the problem now.

This is what happens when I try to install qjail on the host where the ports
tree lives:

<root at catflap(1):/usr/ports/sysutils/qjail>
zsh/3 1001 # make install
===>  Installing for qjail-1.0
===>   Generating temporary packing list
===>  Checking if sysutils/qjail already installed
install: /usr/ports/sysutils/qjail/work/qjail-1.0/qjail-jail2: No such file
or directory
*** Error code 71

Stop in /usr/ports/sysutils/qjail.

<root at catflap(1):/usr/ports/sysutils/qjail>
zsh/3 1007 # ls /usr/ports/sysutils/qjail/work/qjail-1.0/qjail-jail2
ls: /usr/ports/sysutils/qjail/work/qjail-1.0/qjail-jail2: No such file or

The file isn't there.

Bah! Scratch that. Just ran make distclean && make install and it works.

My apologies, Joe, I should have tried that much sooner...  I can only
assume it happened because I installed the port by hand shortly after you
announced its release a few months ago, before it was formally accepted as
part of the tree. I guess I forgot to clean up after that manual test
install and grab the latest version from the ports.

To the originator of this thread - do give qjail a try - it's very good.

~runs away and hides


Daniel Bye
                                              ASCII ribbon campaign ( )
                                         - against HTML, vCards and  X
                                - proprietary attachments in e-mail / \
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 196 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20110620/459f54e9/attachment.pgp

More information about the freebsd-questions mailing list