Xorg upgrade desaster: Xlib: extension "Generic Event Extension" missing on display ":0.0".

O. Hartmann ohartman at mail.zedat.fu-berlin.de
Sat Jan 31 16:38:59 PST 2009

Mel wrote:
> On Friday 30 January 2009 13:19:41 O. Hartmann wrote:
>> After upgrading one of my FreeBSD 8.0-CUR/amd64 boxes to new xorg-7.4
>> and having done hurting recompiling nearly everything/package twice now
>> firefox3 still doesn't work properly and hits me when starting with this
>> error message:
>> Xlib:  extension "Generic Event Extension" missing on display ":0.0".
>> Then firefox3 freezes forever, showing something like the background or
>> pixel remnants of windows/picograms moving over its window.
> http://lists.freedesktop.org/archives/xorg/2008-October/039134.html
Well, that doesn't help very much. As R. Noland wrote, the error coming
up isn't of any harm.

I still have Firefox3 not working on a FreeBSD 8.0-CURRENT/AMD64 UP box,
running the most recent FreeBSD 8.0-CURRENT and having now recompiled
three time EVERYTHING, Firefox3 inclusive. Firefox3 is still stuck when
it comes to pulldown menus or requester for download destination, eating
up 100% CPU time and slowing down the box incredible. I pretty sure I
have all the stuff of the X11 suite in the right place and the right
revision number, as I said, I recompiled everything three times and I
did several attempts upgrading the whole Xorg since sunday last week.
Also a deletion of the ports has been performed and then reinstalled. I
can not asure that there is any zomby-library out there disturbing the
build-process, but I doubt this. I did a 'ldd' on the Firefox3 binary
and  I got the attached dump of the linked shared objects.
Interestingly, the first three entries show up something missing -
therefore I deinstalled Firefox and rebuild the browser after an
additional rebuild of libxcb (via portupgrade -rf). Previously, all Xorg
stuff has been rebuild and by the numbers it seems to be up to date.
I double checked if /usr/local/lib/firefox3 has been completely removed
and for the user's stuff, I deleted the entire ~/.mozilla folder and
started Firefox3 from scratch - everytime with the same result.

Firefox3 did not show these symptomes on a FreeBSD 7.1-STABLE/AMD64 SMP
box, also with most recent sources and undergone the same three time
recompilation of everything procedure. Unlucklily, I do not have another
UP box running FreeBSD 8.0/amd64 for double check this behaviour. Bevor
filing a PR, I would like to ask the list ...

Thanks in advance,


thor# ldd firefox-bin
        libxul.so => not found (0x0)
        libmozjs.so => not found (0x0)
        libxpcom.so => not found (0x0)
        libplds4.so.1 => /usr/local/lib/libplds4.so.1 (0x80063e000)
        libplc4.so.1 => /usr/local/lib/libplc4.so.1 (0x80076f000)
        libnspr4.so.1 => /usr/local/lib/libnspr4.so.1 (0x8008a1000)
        libgtk-x11-2.0.so.0 => /usr/local/lib/libgtk-x11-2.0.so.0
        libatk-1.0.so.0 => /usr/local/lib/libatk-1.0.so.0 (0x800e92000)
        libgdk-x11-2.0.so.0 => /usr/local/lib/libgdk-x11-2.0.so.0
        libgdk_pixbuf-2.0.so.0 => /usr/local/lib/libgdk_pixbuf-2.0.so.0
        libpangocairo-1.0.so.0 => /usr/local/lib/libpangocairo-1.0.so.0
        libgio-2.0.so.0 => /usr/local/lib/libgio-2.0.so.0 (0x801372000)
        libXext.so.6 => /usr/local/lib/libXext.so.6 (0x8014de000)
        libXrender.so.1 => /usr/local/lib/libXrender.so.1 (0x8015ef000)
        libXinerama.so.1 => /usr/local/lib/libXinerama.so.1 (0x8016f8000)
        libXi.so.6 => /usr/local/lib/libXi.so.6 (0x8017fa000)
        libXrandr.so.2 => /usr/local/lib/libXrandr.so.2 (0x801903000)
        libXcursor.so.1 => /usr/local/lib/libXcursor.so.1 (0x801a0a000)
        libXcomposite.so.1 => /usr/local/lib/libXcomposite.so.1
        libXdamage.so.1 => /usr/local/lib/libXdamage.so.1 (0x801c17000)
        libcairo.so.2 => /usr/local/lib/libcairo.so.2 (0x801d19000)
        libpangoft2-1.0.so.0 => /usr/local/lib/libpangoft2-1.0.so.0
        libpango-1.0.so.0 => /usr/local/lib/libpango-1.0.so.0 (0x801fc3000)
        libfreetype.so.9 => /usr/local/lib/libfreetype.so.9 (0x80210a000)
        libz.so.4 => /lib/libz.so.4 (0x802287000)
        libfontconfig.so.1 => /usr/local/lib/libfontconfig.so.1
        libgmodule-2.0.so.0 => /usr/local/lib/libgmodule-2.0.so.0
        libX11.so.6 => /usr/local/lib/libX11.so.6 (0x8025cd000)
        libXfixes.so.3 => /usr/local/lib/libXfixes.so.3 (0x8027cb000)
        libgobject-2.0.so.0 => /usr/local/lib/libgobject-2.0.so.0
        libglib-2.0.so.0 => /usr/local/lib/libglib-2.0.so.0 (0x802a12000)
        libm.so.5 => /lib/libm.so.5 (0x802bcb000)
        libiconv.so.3 => /usr/local/lib/libiconv.so.3 (0x802cea000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x802ecd000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x8030d6000)
        libthr.so.3 => /lib/libthr.so.3 (0x8031e3000)
        libc.so.7 => /lib/libc.so.7 (0x8032fb000)
        libintl.so.8 => /usr/local/lib/libintl.so.8 (0x803525000)
        libxcb.so.2 => /usr/local/lib/libxcb.so.2 (0x80362e000)
        libXdmcp.so.6 => /usr/local/lib/libXdmcp.so.6 (0x803748000)
        librpcsvc.so.4 => /usr/lib/librpcsvc.so.4 (0x80384d000)
        libXau.so.6 => /usr/local/lib/libXau.so.6 (0x803956000)
        libpixman-1.so.9 => /usr/local/lib/libpixman-1.so.9 (0x803a59000)
        libglitz.so.1 => /usr/local/lib/libglitz.so.1 (0x803b91000)
        libpng.so.5 => /usr/local/lib/libpng.so.5 (0x803cba000)
        libxcb-render-util.so.0 =>
/usr/local/lib/libxcb-render-util.so.0 (0x803de1000)
        libxcb-render.so.0 => /usr/local/lib/libxcb-render.so.0
        libexpat.so.6 => /usr/local/lib/libexpat.so.6 (0x803fec000)
        libicui18n.so.38 => /usr/local/lib/libicui18n.so.38 (0x80410f000)
        libpcre.so.0 => /usr/local/lib/libpcre.so.0 (0x804366000)
        libicuuc.so.38 => /usr/local/lib/libicuuc.so.38 (0x804493000)
        libicudata.so.38 => /usr/local/lib/libicudata.so.38 (0x8046c4000)

More information about the freebsd-questions mailing list