broken ports

Dominic Fandrey kamikaze at
Thu Feb 5 02:09:59 PST 2009

David Collins wrote:
> Hi,
> I am not sure if this is better here or in the ports list, but I
> thought that since it is something that I have done because I don't
> know what I am doing here would be better
> A while ago I installed ports and everything was working fine.
> Recently I thought one of my ports was causing my machine to crash so
> I uninstalled it, but later found out that the only problem was a poor
> wireless network and low diskspace. Trying to reinstall the port
> failed at the configure stage. I tried a few others and they also
> failed at the same stage. This leads me to believe that it is
> something I have done.
> So here is the make install error:
> ===>  Script "configure" failed unexpectedly.Please report the problem
> to kuriyama at [maintainer]  and attach
> the"/usr/ports/textproc/expat2/work/expat-2.0.1/config.log" including
> the outputof the failure of your make command. Also, it might be a
> good idea to providean overview of all packages installed on your
> system (e.g. an `ls/var/db/pkg`).
> I found a post saying to try to compile a test program, so I tried that:
> viper:~$ gcc -o hello hello.c
> /usr/bin/ld: cannot find -lgcc_s
> So it appears that I have completely screwed the pooch! Is there
> anything I can do to fix this?
> Thanks
> David Collins

I suggest you give us the complete error message. The lines before the
one you posted ought to be the most interesting ones.

More information about the freebsd-questions mailing list