slow clock on FreeBSD 7.2 on vmware

Robert Fitzpatrick robert at
Wed Dec 16 17:54:01 UTC 2009

On 12/15/2009 9:38 AM, Jacques Manukyan wrote:
> On Sat, 12 Dec 2009 12:06:18 -0500, Robert Fitzpatrick 
> <robert at> wrote:
>> I found posts about this and a possible solution is to disable APIC 
>> by adding hint.apic.0.disabled=1 to /boot/loader.conf. But after 
>> doing so, it booted to the mountroot prompt and would not recognize 
>> my ufs:/dev/da0s1a partition when tried. I went to FixIt and removed 
>> the line from the loader.conf file and it boots fine. I do have some 
>> other things to help the pgsql db on this server in the loader.conf 
>> file, are they interfering?
>> pgsql# cat /boot/loader.conf
>> kern.ipc.semmni=32
>> kern.ipc.semmns=512
>> hint.apic.0.disabled=1
> Try putting:
> kern.hz="50"
> in your /boot/loader.conf

Thanks, that worked. I removed the hint.apic.0.disabled line and put the 
kern.hz line back in except this time with 50 instead of 100 and it 
boots and seems to be keeping time now fine. Since I am a programmer and 
not a system admin, not sure what this does and would like to know, what 
is the kern.hz telling FreeBSD?

> I run multiple FreeBSD servers inside VMWare and I don't have this 
> problem. Are you running VMWare workstation? Or ESX/ESXi?

I am running VMware Server 2.0...thanks again.

More information about the freebsd-questions mailing list