Chicken and egg

Steven Friedrich StevenFriedrich at
Tue Apr 28 17:42:25 UTC 2009

Lowell Gilbert wrote:
> Steven Friedrich <StevenFriedrich at> writes:
>> I've been having trouble with X11 ports, so I deleted all my packages
>> and tried to install xorg fresh.
>> xorg port failed trying to build cairo, cairo failed because it
>> couldn't build libdrm, libdrm failed because cairo's headers weren't
>> installed.
>> So in summary, I can't install cairo because it wants to build libdrm,
>> which won't build/install because it wants cairo.
>> And I tried to install packages or the X11 distro from the ftp site
>> and also from my 7.2 RC-1 media.  I tried setting the Options for
>> "any" as well as RELEASE_7_2_0, to no avail.  My system is up and
>> running multi-user, so sysinstall failed to install any packages.
>> I built cairo with make -k install, so it would brute force past the
>> error, and after that I built libdrm and cairo again with portupgrade
>> -fr libdrm cairo.
> Not only have I not seen or heard of this problem before, I can't see
> any direct dependency of either libdrm or cairo on the other.
pkg_info -r cairo\* shows that cairo needs libdrm.
Information for cairo-1.8.6_1,1:

Depends on:
Dependency: libdrm-2.4.9

If anyone has a has a test system, where they could try my scenario, 
i.e., deleting all installed packages and trying to install xorg, I 
think you'll find it.

I have two identical systems that I have mobile racks in, allowing me to 
swap out the hard drives. So I have 4 sets of drives, Lightning, Daemon, 
FreakinBSD, and Gandalf.  I saw this issue with Daemon.  I need to 
update FreakinBSD and Gandalf, so I'll try this again and get it in a 
log file.

libdrm doesn't build without cairo.h in /usr/local/include, but it won't 
be there until you're built cairo, which depends on libdrm.


Steven Friedrich
Lexington, KY 40509

More information about the freebsd-questions mailing list