fail with wireless network configuration with "SIOCS80211: Invalid argument"

Zhang Weiwu zhangweiwu at
Thu Oct 30 20:52:22 PDT 2008

Paul B. Mahol wrote:
> On 10/30/08, Zhang Weiwu <zhangweiwu at> wrote:
>> Zhang Weiwu wrote:
>>> Hello. I am trying to get an AboveCable (model: ACPC 2000-01) wireless
>>> card connected to my home network with 40-bit Hex WEP Encryption on
>>> FreeBSD 6.1.
>>> # ifconfig wi0 inet ssid ZWW wepmode on wepkey 0xea82552825
>>> ifconfig: SIOCS80211: Invalid argument
> Why is "deftxkey 1" missing ?
> from ifconfig(8)
>              Note that you must set a default transmit key with deftxkey for
>                            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
>              the system to know which key to use in encrypting outbound traf-
>              fic
That quoted line of text is not appearing in my version (6.4) FreeBSD's

I tried to add "deftxkey 1", same result. a.k.a. the interface is
configured, but DHCP couldn't obtain IP address, manually assigned IP
address couldn't communicate with other hosts.

More information about the freebsd-questions mailing list