Can't add new 1TB disk in FreeBSD 6.1

Jeremy Chadwick koitsu at
Sun Oct 5 01:30:19 UTC 2008

On Sat, Oct 04, 2008 at 04:43:14AM -0700, Don O'Neil wrote:
> I just swapped out an old 500G disk with a 1TB one and I'm trying to label
> it and mount it...
> If I run bsdlabel -w ad4, I get:
> bsdlabel: Geom not found
> If I run sysinstall, it tells me that it can't write to the disk.
> I've tried an old 'bypass': sysctl kern.geom.debugflags=16, but that didn't
> help.
> Can anyone help me get this new disk installed without having to boot off a
> recovery CD? The server is 500 miles away from me and I don't have direct
> console access.

Can you provide output from dmesg, as well as "geom disk list"?

| Jeremy Chadwick                                jdc at |
| Parodius Networking              |
| UNIX Systems Administrator                  Mountain View, CA, USA |
| Making life hard for others since 1977.              PGP: 4BD6C0CB |

More information about the freebsd-questions mailing list