Success! ( was - can't mount USB key as user )

Andy Elvey andy.elvey at
Tue Jan 8 22:29:22 PST 2008

usleepless at wrote:
> hmmm, seems to be broken for me....
> - man devfs.rules
> - create /etc/devfs.rules: ( substitute wheel for the group you want )
> [localrules=10]
> add path 'da*s*' mode 0660 group wheel
> - append to /etc/rc.conf:
> devfs_system_ruleset="localrules"
> - make sure the dir you are mounting on is owned by the user who
> issues the mount command.
> - make sure vfs.usermount=1
> - reboot after changing devfs.rules & rc.conf
> worked for me, let us know if it worked for you.
> regards,
> usleep
  Hi again - 
  Success!   I can now mount USB devices as a user - thanks very much 
for your help usleep! 

 One of the things that helped (as it usually does ;)   )  was having a 
careful re-read of the docs for USB devices.  When I did that, I found 
that for some silly reason, instead of having
'da*'   in my /etc/devfs.rules file, I had 'da*s*'  .    ( Argh..... 
applies face firmly to keyboard..... ).   Anyway, that now works perfectly.

I have more good news.  The above stuff was for my USB key.  I also have 
an external USB hard-drive (with the Linux ext2 filesystem on it).  When 
I tried that, at first it didn't work (not surprisingly).  A quick 
search on the net gave me a page that mentioned "kldload'  (which I've 
never heard of - anyway, as I thought, it loads modules into the kernel). 

The example given was for reiserfs, but I tried (as su)  "kldload 
ext2fs"  and then (as normal user)  "mount -t ext2fs /dev/da0s1  
/mnt/andy"  and it worked!  

Ahh... now I can get into the thing I've really been looking forward to 
-  pf  :-)  .   That should probably have me being nervous, but it 
doesn't.   I've already done a lot of reading-up on it -
it sounds great, and you've got to have a heap of respect for the guy 
who wrote it.    I've already found out about pftop and so on, so that 
should come in handy....
Bye for now -
- Andy

More information about the freebsd-questions mailing list