6.2 Headless Installs Don't Seem to Work.

Martin McCormick martin at dc.cis.okstate.edu
Thu Sep 20 14:17:59 PDT 2007

Watanabe Kazuhiro writes:
> Try:
>  console="comconsole,vidconsole"
>  boot
> instead of "boot -h".

	First, thanks for an excellent suggestion. I tried it
and have not been successful so far. During the pause, I hit 6
and got control of the boot process. I typed
console="comconsole,vidconsole", hit Enter and then the word
boot  at which time the booting process resumed. It came up in
video console mode, completely ignoring the directive.

	The FreeBSD Handbook has a chapter on "Setting up the
Serial Console" (24.6), which explains the -h and -D flags, the
-D flag allowing for a Duel video and serial console. It also
has a very interesting passage, quoted here:

                Toggles single and dual console configurations. In the
                single configuration the console will be either the
                internal console (video display) or the serial port,
                depending on the state of the -h option above. In the
                dual console configuration, both the video display and
                the serial port will become the console at the same time,
                regardless of the state of the -h option. However, note
                that the dual console configuration takes effect only
                during the boot block is running. Once the boot loader
                gets control, the console specified by the -h option
                becomes the only console.

End of quote.

	That hard lockup I described in an earlier message is
not what I thought it was. It isn't a lockup for the whole
booting process, but a lockout of the serial console. It is as
if the -h flag gets turned off after the boot block runs. Either
the -h or the -D flags produce exactly the same results. You do
get the serial console during the kernel boot as expected and
then it reverts back to the local video console just after the
message I quoted in an earlier message that says, "Trying to
mount /root on /dev/md0."

	This makes a certain amount of sense even if it is the
wrong behavior. The documentation says that only the duel mode
should behave this way and then the kernel goes to whatever mode
-h told it to use. That is apparently what is not happening.

	If I do just the 


I get nothing serial at all. When I install a 6.2 kernel and put
that command in /boot/loader.conf, it works on the serial port

	All versions of FreeBSD up to 6 did continue to work via
the serial port so that one could do the whole installation via
that method so whatever broke was introduced in FreeBSD6 if that
helps narrow things down any.

	Thanks for any further suggestions.

	I did go ahead and enlist the aid of a coworker on this
system so the immediate problem is solved, but I have been
experimenting with the CD this afternoon to see if the
suggestion solved the problem. It should have so this is a bit

Martin McCormick WB5AGZ  Stillwater, OK 
Systems Engineer
OSU Information Technology Department Network Operations Group

More information about the freebsd-questions mailing list