very poor NFS performance from a beta3

Jonathan Horne freebsd at dfwlp.com
Sun Nov 18 06:37:30 PST 2007


On Sunday 18 November 2007 05:59:12 am Kris Kennaway wrote:
> Jonathan Horne wrote:
> > i updated my workstatino to beta3, and then got on a 6.2-p8 machine and
> > mounted /usr/src and /usr/obj from the beta3.   tried to installkernel,
> > but it moved as painful pace.  would get to the point where it moves
> > kernel to kernel.old, and would just pause for a long time.  file
> > transfer showed about 104k.
> >
> > i took this same 6.2-p8 box, and mounted src and obj from my main 6.2
> > build server, and reinstalled the 6.2-p8 kernel, and speed was as
> > expected.
> >
> > is there anywhere i can being looking to troubleshoot this problem (as to
> > why the 7.0b3 would serve NFS so slowly)?
>
> This is usually because your NIC has mis-negotiated and is unable to
> pass packets properly.
>
> Kris

kris, thanks for your reply.  whats the best way to tell if i have 
mis-negotiated?  is just 'ifconfig' sufficient?  i was wondering about this 
earlier, and reboots of the hosts as well as the switches yielded no 
different results.

also, i did a few other tests as well.  i can scp to/from the 7.0b3 and 6.2p8 
from/to each other as well as other hosts on the network at what i would call 
normal speeds (6-10 megabytes/sec).  also, i can 'cp -vpnRP' directory trees 
from/to the same with normal results.  only installing kernel from the 7.0 to 
the 6.2 stalls out.
-- 
Jonathan Horne
http://dfwlpiki.dfwlp.org
freebsd at dfwlp.com


More information about the freebsd-questions mailing list