Xorg failed to run on old PC.

Norberto Meijome freebsd at meijome.net
Thu Jun 28 11:31:19 UTC 2007

On Thu, 28 Jun 2007 08:21:20 +0200
David Marec <dmares.spam at free.fr> wrote:

> hi

Hi David,
[ originally sent to ports@ - this should really go in questions@, not really
to do with the ports systems. therefore,i've moved it.]

> I am trying to configure an old "cirix166-48Mo RAM" workstation.

you mean 48 Mb ? 

> But, FreeBSD 6.2 installed, Xorg crashes on 
> « Caught signal 11»

segfault 11 is, if memory serves me well, usually caused by dodgy hardware.
(RAM / L1 cache usually)

> I tried three drivers, mga, vesa and vga.

ok, from your Xorg log file, you have a 

Matrox Graphics, Inc. MGA 1064SG [Mystique]

card. mga 'should' be the right one, but i wonder whether it would try too hard
to get all the bells and whistles running, which may not be such a good idea in
an old machine. 

> The driver "mga" failed to load DRI module, which was not requested.

you can disable DRI  in your xorg.conf by commenting out the 

Load "dri"

I am not sure how to do it with a blank xorg.conf though. there should be some
parameter for xorgcfg (you are using it to generate a valid xorg file , right? )

> The log file, created with no "xorg.conf", can be uploaded here:
> http://david.marec.free.fr/public/Xorg.0.log
> It seems that i had the same problem when i tried to launch XUbuntu on it.

i imagine xubuntu is assuming newer hardware, and therefore more 'features'
enabled, which will definitely cause some problem for you.

> The only linux distribution that works is Damn Small Linux.

for (the same reasons)^(-1) as above.

{Beto|Norberto|Numard} Meijome

If you were supposed to understand it, we wouldn't call it 'code'.

I speak for myself, not my employer. Contents may be hot. Slippery when wet.
Reading disclaimers makes you go blind. Writing them is worse. You have been

More information about the freebsd-questions mailing list