Problem with openldap-sasl-client port?

Robert Fitzpatrick lists at webtent.net
Sat Jun 23 15:40:09 UTC 2007


I posted the other day, trying to install SA 3.2, it keeps attempting to
install openldap-sasl-client-2.3.36 even though it is already there. I
tried 'pkg_delete -f' and then portinstall of the ldap client, I've
tried to register FORCE_PKG_REGISTER. Whenever I run 'pkgdb -F', the
ldap client deps want to link to the openldap-server-2.3.36. Am I going
to have to uninstall all deps fro the ldap client and re-install? Will
that work...

mx1# pkg_delete openldap-sasl-client-2.3.36
pkg_delete: package 'openldap-sasl-client-2.3.36' is required by these other packages
and may not be deinstalled:
amavisd-new-2.5.0,1
apache-2.2.4_2
dirmngr-0.9.7_2
gnupg-2.0.3
openldap-server-2.3.36
pear-1.5.4
pear-Auth-1.5.0
pear-Auth_SASL-1.0.2
pear-DB-1.7.11,1
pear-File_Passwd-1.1.6
pear-Log-1.9.10
pear-Mail_Mime-1.4.0,1
pear-Net_IMAP-1.0.3
pear-Net_POP3-1.3.6
pear-Net_SMTP-1.2.10
pear-Net_Socket-1.0.7
pear-Pager-2.3.4
pear-SOAP-0.10.1
php5-5.2.2
php5-gettext-5.2.2
php5-ldap-5.2.2
php5-mysql-5.2.2
php5-openssl-5.2.2
php5-pcre-5.2.2
php5-pgsql-5.2.2
php5-session-5.2.2
php5-wddx-5.2.2
php5-xml-5.2.2
postfix-2.4.3,1
postgresql-server-8.2.4_1
smarty-2.6.18
mx1# pkgdb -F
--->  Checking the package registry database
[Updating the pkgdb <format:bdb_btree> in /var/db/pkg ... - 505 packages found (-1 +1) (...). done]
Stale dependency: amavisd-new-2.5.0,1 -> p5-Mail-SpamAssassin-3.2.0 (mail/p5-Mail-SpamAssassin):
p5-Mail-SPF-Query-1.999.1 (score:56%) ? ([y]es/[n]o/[a]ll) [no]
Install stale dependency? ([y]es/[n]o/[a]ll) [yes] no
New dependency? (? to help):
Skip this? ([y]es/[n]o/[a]ll) [yes]
Skipped.
Stale dependency: nagios-2.9_1 -> openldap-client-2.3.35 (net/openldap23-client):
openldap-server-2.3.36 (score:52%) ? ([y]es/[n]o/[a]ll) [no] ^C

-- 
Robert



More information about the freebsd-questions mailing list