beryl/agpgart/i810/Intel 950 GMA

Reid Linnemann lreid at
Thu Jun 14 13:10:50 UTC 2007

Written by Eduardo Viruena Silva on 06/13/07 21:07>>
> Hello Guys,
> I have an Intel 950 GMA video card,
> built-in in my computer's motherboard.
> My motherboard is D945NT.
> I installed FreeBSD-6.2-RELEASE, and cvsupdated
> it to FreeBSD-6.2-RELEASE-p5.
> Installed my ports and cvsupdated them.
> I found "beryl"  in /usr/ports/x11-wm, it
> seemed to depend on Xorg-7.2
> I successfully upgrade Xorg-6.9 to Xorg-7.2.
> I also compiled beryl, everything seems to be ok.
> ..and I have tried to make it work, I give up.
> The problem seems to be that X is
> trying to find /dev/agpgart, according
> to my /var/log/Xorg.0.log:
> (II) I810(0): VESA VBE OEM Vendor: Intel Corporation
> (II) I810(0): VESA VBE OEM Product: Intel(r) 82945G Chipset Family 
> Graphics Controller
> (II) I810(0): VESA VBE OEM Product Rev: Hardware Version 0.0
> (II) I810(0): Integrated Graphics Chipset: Intel(R) 945G
> (--) I810(0): Chipset: "945G"
> (--) I810(0): Linear framebuffer at 0x40000000
> (--) I810(0): IO registers at addr 0x50100000
> (==) I810(0): Write-combining range (0x50100000,0x80000) was already clear
> (II) I810(0): 2 display pipes available.
> (II) I810(0): detected 7932 kB stolen memory.
> (EE) GARTInit: Unable to open /dev/agpgart (No such file or directory)
> (WW) I810(0): /dev/agpgart is either not available, or no memory is 
> available
> for allocation.  Using pre-allocated memory only.
> (--) I810(0): Pre-allocated VideoRAM: 7932 kByte
> I have seen beryl working on Gentoo Linux,
> /dev/agpgart is present in an identical system,
> and it seems to me that it is not a problem
> of memory allocation.
> so...
> What do I have to do to create /dev/agpgart?
> My kernel has
>     device     agp
> present.
> Thank you in advance.
>          Eduardo.
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to 
> "freebsd-questions-unsubscribe at"

It looks to me like you don't have working dri/drm. You have to have 
direct rendering working before you can get beryl working. AFAIK, drm 
support for your chipset is not available in 6.1-RELEASE, and the drm 
module is what provides the agpgart device.

sys/dev/drm/drm_pciids.h on 6-STABLE from about February shows this:

#define i915_PCI_IDS \
         {0x8086, 0x3577, 0, "Intel i830M GMCH"}, \
         {0x8086, 0x2562, 0, "Intel i845G GMCH"}, \
         {0x8086, 0x3582, 0, "Intel i852GM/i855GM GMCH"}, \
         {0x8086, 0x2572, 0, "Intel i865G GMCH"}, \
         {0x8086, 0x2582, 0, "Intel i915G"}, \
         {0x8086, 0x2592, 0, "Intel i915GM"}, \
         {0x8086, 0x2772, 0, "Intel i945G"}, \
         {0x8086, 0x27A2, 0, "Intel i945GM"}, \
         {0, 0, 0, NULL}

So you have to have the i915 module loaded to use this chipset. Though 
the i915 driver was ported for 6.1-RELEASE there was no Makefile 
included, and it never really worked until after 6.2-RELEASE. 
Personally, I'm tracking 6-STABLE and I've had drm working with an i845G 
  since February of this year when anholt MFC'd a load of i915 drm 
changes. See this log for more info:

More information about the freebsd-questions mailing list