portupgrade -o oddness...

illoai at gmail.com illoai at gmail.com
Fri Jun 8 06:34:33 UTC 2007

On 07/06/07, Josh Tolbert <hemi at puresimplicity.net> wrote:
> Hello,
> Having successfully completed my update from Xorg 6.9 to Xorg 7.2, I decided
> to install a few things, one of which required devel/bison2 instead of bison.
> Usually, portupgrade -o would handle this for me, but lately it seems like
> portupgrade -o doesn't want to replace ports. Has anyone else noticed this or
> is there a known workaround/fix?
> (15:38:21 <hemi at demon:~>) $ pkg_info | grep bison
> bison-1.75_2,1      A parser generator from FSF, (mostly) compatible with Yacc
> (15:38:30 <hemi at demon:~>) $ sudo portupgrade -o devel/bison2 bison
> (15:38:34 <hemi at demon:~>) $ sudo portupgrade -fo devel/bison2 bison
> --->  Reinstalling 'bison-1.75_2,1' (devel/bison)
> The same problem occurred when I tried to replace ghostscript-gnu with
> ghostscript-gpl as well.
> I'm using portupgrade-devel instead of portupgrade.

Confirmed, -o worked as advertised here
before the move to portupgrade-devel and
now does not.


More information about the freebsd-questions mailing list