fresh install - compaq laptop locks up on boot after timecounter TSC

Micah micahjon at
Sat Jan 6 15:52:44 UTC 2007

Steve Franks wrote:
> This is why no one ever got fired for buying an IBM as the old adage goes.
> My ancient Dell laptop had absolutely no install issues, so I bought a 
> fresh
> disk for my shiny new compaq:
> Behavior is identical off of 6.1-current cd or install to ad0 that was
> completed from cd safemode boot.  She runs fine in safemode from acd0 or
> ad0.  Regular startup - see vga0 go by sucessfully, then
> timcounter TSC...
> ....ticks at 1 milliseconds....
> then locks up tight.  I tried disabling the line after vga0 in
> boot/device.hints, but those of you who know what that is know, I'm sure,
> that that turns my system into a peperweight.
> I also tried boot with acpi disabled, but that seems to lock up identically
> on tsc.
> Wish I had more info, but that's all I can glean without more help.  Had to
> put the origonal harddisk with winXP back in.  No one wants that ;)  Save
> me!
> Steve

Sounds similar to the problem my Compaq has/had. I found that the 
following advice, posted to questions@ some time ago, worked for me:

 > Interrupt the kernel loading process, then:
 > set hint.sio.0.disabled=1
 > set hint.sio.1.disabled=1
 > set hint.atkbd.0.flags=0x9


More information about the freebsd-questions mailing list