Tyan S5197 and ACPI don't mix on 6.2 Re: 6.2-RELEASE amd64 system rebooting under heavy load with Areca ARC-1231ML

Chad Leigh -- Shire.Net LLC chad at shire.net
Fri Aug 31 10:34:24 PDT 2007

On Aug 21, 2007, at 2:53 AM, Chad Leigh -- Shire.Net LLC wrote:

> Hi
> I have a new system I am building.
> Tyan S5197 MB with Intel Core 2 Quad 2.4ghz, 4GB RAM
> Areca ARC-1231ML raid card.  5 320gb disks in a RAID6 with 1 320gb  
> disk hot spare plus two 750gb in a raid1 mirror.  Using the ARECA  
> firmware, each raidset is subdivided into separate volumes that  
> each appear to the OS as separate daN type disks.
> I read through Google about various problems that the Areca driver  
> had as well as on the Areca website FAQ (on FreeBSD)
> I installed 6.2-RELEASE on this system.  Under heavy IO load the  
> system reboots itself.  This happened both in trying to install the  
> OS, and if I got that far, in trying to build cvsup tool or in  
> building a new kernel.  The machine could sit there idle for hours  
> but you startup a large build and usually withing a few minutes  or  
> 10 minutes it would reboot itself.  I tried installing the 6.2- 
> STABLE snapshot (latest on in the downloads which is from June) but  
> the whole system would lock up after a few minutes and I would get  
> corruption on the console screen so I decided that was not a great  
> plan.  I also tried the 7-CURRENT as a test but that would not stay  
> out of the kernel debugger.
> So I went back to 6.2-STABLE.  I installed it and then copied the  
> areca kernel driver source  arcmsr.c/.h from the 6.2-STABLE  
> snapshot from June (latest snapshot I could find) and used it to  
> rebuild the kernel.  I was then able to build cvsup and do a cvsup   
> to the latest -RELEASE code and was a significant way through a  
> buildworld when it happened again and rebooted itself.  So it  
> appears the problem is not yet solved.
> Is anyone out there running a form of 6.2 on an x64 type platform  
> using an Areca controller?  What is the latest 6.x compatible  
> driver source for the Areca?  I tried to copy the 7-CURRENT areca  
> source back but it relies on the new CAM system and even if I added  
> that option to my 6.2 there were a bunch of compilation errors that  
> made it look like the 7.0-CURRENT IO or SCSI or whatever lower  
> level it uses  system has changed.
> Any help in figuring out how to get this up and running without  
> these reboots under load would be greatly appreciated.

After replacing the power supply with a beefier one, running  
memtest86 for a day, trying to install Solaris 10 with the same  
reboot issue, etc, I tried running with boot without ACPI and that  
seems to have cured the issue.  So there seems to be an issue with  
the Tyan S5197 board and ACPI on 6.2-RELEASE (and on Solaris 10u3)


Chad Leigh -- Shire.Net LLC
Your Web App and Email hosting provider
chad at shire.net

More information about the freebsd-questions mailing list