Trying to move /usr

Michael S msherman77 at
Mon Aug 20 08:10:14 PDT 2007

Good morning everyone,

I am trying to migrate my /usr to a newly installed
SCSI drive. Up until yesterday I had /, /var, /usr on
a 5 Gig drive and my /home was on another 60 Gig
drive, which was fine because it had no GUI and
functioned mostly as a server.

Last night I added a third drive, with a capacity
around 18G; since my other two drives are hard-wired
in /boot/device.hints, there were no problems with
device numbering. I wrote down the device name
(/dev/da2) and proceeded to sysinstall to first create
a FreeBSD partition and then the only slice within
that partition. I named it /user.

I then tarred up /usr
Tar –cf  /user/usr.tar /usr

Extracted the tar file and moved everything one
directory up, because otherwise everything were under

I made the necessary adjustnments in /etc/fstab, that
is I switched /usr and /user around.

After reboot, I wasn’t getting the prompt, since the
binaries for displaying the prompt are located under
/usr/bin (or /usr/sbin?) and my guess was that /usr
wasn’t mounting properly. I restarted the machine,
this time going into single user mode. Trying to mount
–a gave me an error message: Error mounting /usr/home.
I then created home directory under the new /usr, I
tried mount –a, this time it worked, but when I
rebooted, I wasn’t getting my home directory. When I
login as an unprivileged user – michael, the message
is something like: “User has no home directory”.

For now I reverted to using the old /usr.

Anyone attempted to migrate /usr and fell for similar
kind of problems? Any suggestions will be appreciated.

P.S. I am not next to that machine right now, so I
can’t provide the exact fstab or dmesg output.

Thanks in advance,

More information about the freebsd-questions mailing list