GnuPG, pinentry, and Qt

Chad Perrin perrin at
Thu Aug 2 10:24:10 UTC 2007

On Thu, Aug 02, 2007 at 02:35:35AM -0600, Chad Perrin wrote:
> So I tried installing GnuPG on a FreeBSD 6.2-RELEASE system.  It doesn't
> work without pinentry installed.
> Okay, I can handle that.  No big deal.  Apparently GnuPG 2.x requires a
> separate utility for password handling now.  No big deal.  I run
> portinstall pinentry.
> At this point, I notice something very, very odd: pinentry won't install
> because of a problem with Qt.
> Why the heck would GnuPG ultimately depend on Qt in any way?

Okay . . . so I should have looked a little harder at the pinentry ports
available before sending this email to the list.  Apparently there are
three different versions.  I'm still curious about a couple of things,

  1. Why is Qt the default for the nonspecific security/pinentry port?
  2. Why start a separate, external application for getting the
  passphrase at all?

CCD CopyWrite Chad Perrin [ ]
awj @reddit: "The terms never and always are never always true."

More information about the freebsd-questions mailing list