hard drive problems

Donald Creel donxc at verizonmail.com
Sun Nov 5 14:13:53 UTC 2006

My apologies if this is wrong list. 
I have a Vaio PCG-9251 laptop with a Seagate Momentus 20G hard drive that has been working great 
with 6.1 release. I had left it powered down for about 5 weeks, then on powerup, it was booting 
fine until it started bringing the wireless online. I noticed that it was showing errors on ad0 but 
it eventually made it through all the rc stuff and got to the login. Still getting errors so I 
tried fsck_ufs which failed with numerous bad sectors and then eventually showed the disk detached. 
What I have tried: 
1.) Boot with cd from 6.1 package set, create /etc/fstab on md00 with /dev/ad0 params, running 
fsck_ufs again. 
Sometimes it reads disks and gives bad sector errors, other times it just says ad0 detached and 
returns error codes. Sometimes it seems to be making the corrections that I am prompted to let it 
do, but the end reault is the disk is detached. 
2.) Re-installing from the CD, but it always returns error that it couldn't write partition table 
to the disk. 
3.) Formating with a Win98 startup disk. Always fails. 
4.) Removed the drive from the machine and installed old win98 drive which works as expected. 
I am not finding much help in my searches for these problems, so hopefully someone here can give 
the clueless a clue. 
Is there a way to re-attach the disk? 
Should I just trash it and replace it or is there any hope for it? 
I really don't have anything important on it, but I don't want to fork out money for new one if I 
don't have to. 
Please cc me as I am not subscribed to this list. 


Search for products and services at: 

More information about the freebsd-questions mailing list