Problem with enabling soft-updates via tunefs

Sergey Kovalev skoval at
Tue Mar 21 23:39:12 UTC 2006

Several weeks ago I tried enabling soft-updates on / partition of active 
file system in multi-user mode via
tunefs -n enable /dev/ar0s1a
having remounted it read-only.
After that I just rebooted the system and according to mount 
soft-updates were enabled. (I tried remounting / partition to RW w/o 
rebooting but mount showed soft-updates were disabled).
I was rather satisfied that it is possible w/o making newfs, but today I 
the same actions didn't work on another system (almost the same hardware 
except MB). (I even tried them on the first one, but there everything 
still worked fine).

On second system I got an error something like:
/dev/ar0s1a: can't write superblock information
(to my regret I can't remember exactly but I can repeat if necessary)

Differences between system:
1) / partition is the first on disk (256 Mb)
2) FreeBSD-5.4-RELEASE-p8 (with patch fixing soft-updates' problem with 
inodes); link to patch
3) Custom kernel (i can provide kernel configuration if necessary)
1) / partition was the only partition on disk (approximately 65 Gb); 
there was also second 2 Gb swap partition
2) FreeBSD-6.0-RELEASE
3) GENERIC kernel

Is there a possibility to enable soft-updates on large / partitions at 
all or there may be something else?

More information about the freebsd-questions mailing list