DHCP not working

Nathan Vidican nvidican at wmptl.com
Wed Mar 1 12:02:07 PST 2006

Pietro Cerutti wrote:
> Hi List,
> I can't get a DHCP lease from my cable modem, here are the details:
> - The PC is a P4 500 MHz running 6.0-RELEASE just installed, GENERIC.
> - I tried with three different NICs, without result:
> -> a 3Com 3C509 (driver vx),
> -> a RealTek (can't remember the model, is about one year old)
> (obviously driver rl),
> -> and a D-Link DFE-528TX (driver rl).
> - The first two NICs are OK with static IP assignement, worked for
> more than 1.5 years on 5.2.1-RELEASE and 5.4-RELEASE, I didn't tested
> the last one since I just bought it today...
> - The modem is OK, no problems with:
> -> a laptop (i386 6-STABLE),
> -> another laptop (Ubuntu),
> -> a desktop PC (Win XP).
> - My laptop has an integrated RealTek 8139C+ (driver re), and the
> dhclient configuration is the same as the PC where the problem is
> (default config), therefor the problem shouldn't be in the
> configuration.
> - I don't know if it's important, but the DHCP client never worked,
> neither during sysinstall
> - I tried disabling PnP OS in the BIOS, as I read in some forums, but nothing
> Any ideas?
> If more detailed infos are needed, please ask!
> Thank you in advance!
> --
> Pietro Cerutti
> <pietro.cerutti at gmail.com>
>    Non lasciar calpestare i TUOI diritti!
>    Don't let 'em take YOUR rights!
>    NO al Trusted Computing!
>    Say NO to Trusted Computing!
>    www.no1984.org
>    www.againsttcpa.com
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at freebsd.org"

Call your cable/internet provider. Some cable modems/providers limit the number 
of DHCP/mac addresses allowed per connection, here in our area the limit is 3, 
after than you have to pay for more. Have run into issues before, just call 
company and explain that MAC "xx:xx:xx..." is your new NIC and you can't get a 
dhcp lease with it, then ask if there is something they have blocking it?

That would be my first thing to try, second would be to utilize a different 
network (cheap $20 dsl/cable router oughta work - try it isolated and see if it 
gets a dhcp lease) - that way you rule out the issue being the network vs the 
machine vs the software.

Nathan Vidican
nvidican at wmptl.com
Windsor Match Plate & Tool Ltd.

More information about the freebsd-questions mailing list