Portupgrade install errors

Andrey Slusar anrays at gmail.com
Fri Jun 23 12:51:03 UTC 2006


Fri, 23 Jun 2006 10:59:16 +0200, Andreas Wideroe Andersen wrote:

> I can't seem to install portupgrade on my system. I'm running 4.7
> STABLE (and I can't upgrade until later in July).

> /usr/ports/sysutils/portupgrade #] make install clean
> "/usr/ports/Mk/bsd.port.mk", line 1618: warning: String comparison
> operator should be either == or !=
> "/usr/ports/Mk/bsd.port.mk", line 1618: Malformed conditional
> (${OSVERSION} < 504105 ||  (${OSVERSION} >= 700000 && ${OSVERSION} <
> 700012) ||  (${OSVERSION} >= 600000 && ${OSVERSION} < 600104))
> "/usr/ports/Mk/bsd.port.mk", line 1618: Missing dependency operator
> "/usr/ports/Mk/bsd.port.mk", line 5651: if-less endif
> "/usr/ports/Mk/bsd.port.mk", line 5651: Need an operator
> make: fatal errors encountered -- cannot continue

> Any idea?

  Try this patch:
--8<---------------cut here---------------start------------->8---
--- bsd.port.mk.orig	Fri Jun 23 12:10:41 2006
+++ bsd.port.mk	Fri Jun 23 12:11:30 2006
@@ -1613,11 +1613,7 @@
 LDCONFIG32_DIR=	libdata/ldconfig32
 
 .if defined(USE_LDCONFIG) || defined(USE_LDCONFIG32)
-.if ${OSVERSION} < 504105 || \
-		(${OSVERSION} >= 700000 && ${OSVERSION} < 700012) || \
-		(${OSVERSION} >= 600000 && ${OSVERSION} < 600104)
 RUN_DEPENDS+=	${LOCALBASE}/${LDCONFIG_DIR}:${PORTSDIR}/misc/ldconfig_compat
-.endif
 .if defined(USE_LDCONFIG) && ${USE_LDCONFIG:L} == "yes"
 USE_LDCONFIG=	${PREFIX}/lib
 .endif
--8<---------------cut here---------------end--------------->8---



More information about the freebsd-questions mailing list