DL360 G4 shared network iLo and FreeBSD

Norberto Meijome freebsd at meijome.net
Sun Jul 16 13:56:58 UTC 2006

On Sat, 15 Jul 2006 14:13:57 -0700
Eric Lakin <elakin at infohell.net> wrote:

> I'm trying to setup a DL360 G4 for use in a colo environment with
> FreeBSD. I've run into one problem: I've setup the iLo to use the
> "shared network" option, which allows the iLo to share the same network
> interface as the host computer. But the iLo hangs whenever the FreeBSD
> kernel loads.

FWIW, we have a bunch of 360s but running the iLo independently from the main
card. They work just great, but never tried them on the other setting.

> When booting the system, it gets this far before the ilo is hangs:
>  ?  Select option, [Enter] for
> default     ? ?  or [Space] to pause timer
> 2           ? ???????????????????????????????????????????                                    
> Copyright (c) 1992-2006 The FreeBSD
> Project. Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993,
> 1994 The Regents of the University of California. All rights reserved.       
> FreeBSD 6.1-RELEASE-p2 #0: Sat Jul 15 01:36:17 PDT
> 2006
> elakin at amun-ra.priv.infohell.net:/usr/obj/usr/src/sys/SMP ACPI APIC Table:
> <HP     00000083>  
> The system continues to boot OK, so I can provide further information as
> needed. When the ilo is hung, it no longer responds to pings/ssh. As
> soon as FreeBSD is rebooted, the iLo becomes responsive again without
> any intervention. I've also tried loading a test linux installation, to
> see if the same thing happens. The iLo continues to function normally
> (doesn't hang) when running linux.
> Anybody have an idea what FreeBSD is doing to hang the iLo in this
> situation, and how to keep it from doing so?
> _______________________________________________

More information about the freebsd-questions mailing list