User permissions to mount CDROM

ajm ajm91qw at
Sun Aug 27 20:32:46 UTC 2006

On Sun, Aug 27, 2006 at 08:11:16PM +0530, Viswas Nair wrote:
> I have been trying to figure out how to give users to mount CD rom and have
> been largely unsuccessful. Here are a few things I tried:
> 1) Added user to the 4th field (options) in /etc/fstab
> 2) Added vfs.usermount=1 to  sysctl.conf
> 3) Created a group called optical and added the root and alpha to it
> 4) Added following lines to devfs,conf :
> own /dev/acd0 root:optical
> perm /dev/acd0 0770
> own /dev/acd1 root:optical
> perm /dev/acd1 0770
> 5) Rebooted machine and tried to mount /dev/acd0 into /cdrom and it failed
> with the message:
> got the error message: /dev/acd0

Try the following:  create a subdirectory in the users home directory.
example:  /home/steven/cdrom

mount_cd9660 /dev/acd0 /home/steven/cdrom

also, you can change the permission to 550
(read/execute by owner and group) no need for write permission.
make sure that your users are part of the optical group.
One more thing...users will not be able to mount anything to /cdrom
since it will belong to root/wheel.  Hope this helped you.


More information about the freebsd-questions mailing list