Continous JAVA build error on AMD64 and i386

O. Hartmann ohartman at
Thu Sep 29 07:43:47 PDT 2005

I reported earlier in this list about trouble in building and installing 
   JAVA on both AMD64 and i386 architectures.
In the meanwhile, I can compile ports/jdk15 on AMD64/FreeBSD-6.0, but 
jdk15 does not include or have the desired plugin for Mozilla/FireFox, 
so I tried compiling ports/jdk14. I got every recent and needed file for 
this compilation, but although I compiled "LINUX32" __and__ COMPAT32 
options into kernel (also procfs and linprocfs and everything is 
installed and working correct), I receive the the message: this port is 
for i386 and you are running amd64. That's really nice.

So I tried compiling jdk14 and jdk15 on an DELL Optiplex 280 running 
FreeBSD 6.0 (most recent buildworld as with the amd64 box!). I never had 
success compiling either jdk14 or jdk15, both end up in the attached 
error of mising BOOTDIR environment.
Examining the log output shows some curiuous portions:

    JAVAWS_BOOTDIR = /usr/local/linux-sun-jdk1.4.2
-->BOOTSTRAP J2SDK VERSION: Segmentation fault
    OUTPUTDIR = /usr/ports/java/jdk14/work/control/build/bsd-i586

This seems to be a fault in the Linux environment. I tried either 
Linuxulator as loadable kernel module or fixed compiled into kernel, 
with no success.

Deinstalling everything belonging to Linux and doing a fresh install via 
dependencies while installing jdk14/jdk15 doesn't result in any suitable 
  situation, I reiceive always the same error.

What's up?


More information about the freebsd-questions mailing list