AW: PPPoE to connect to T-DSL

Schleich, Arno A.Schleich at
Sat Sep 10 01:19:32 PDT 2005


Tx a lot, I managed to connect as root. Your ppo.conf was nearly identical to trhe one I had used with the exception to 'disable lqr' (I had it enabled) and 'set echoperiod 30'/ 'enable echo'. After adding these it worked, don't ask me why.
Still have the problem of no ppp as an ordinary user (member of wheel, network), Is there anything I need to do besides adding 'allow users <user_name> ?

Thanks, Arno

-----Ursprüngliche Nachricht-----
Von: cpghost [mailto:cpghost at] 
Gesendet: Donnerstag, 8. September 2005 15:08
An: Schleich, Arno
Cc: freebsd-questions at
Betreff: Re: PPPoE to connect to T-DSL

On Thu, Sep 08, 2005 at 02:32:19PM +0200, Schleich, Arno wrote:
> I just need to connect my notebook to the internet using pppoe to hook
> up to t-dsl, a German adsl provider.
> I installed 5.4 Release with very few problems.
> Anyway, trying to use the most generic ppp.conf it hangs in 'Phase' (as
> far as I can understand the log). It redials and redials, which results
> in multiple
> deflink: Connected
> deflink: Hangup
> sequences in the /var/lod/ppp.log. Btw, I upped the rl0 interface prior
> to starting ppp, so I hope this is not an issue. There is no activity on
> the LEDs of the dsl modem.

Hello Arno,

I know definitely that the following configuration works with
kamp-dsl, a provider that uses t-dsl (yes, on FreeBSD 5.4-STABLE).


  set log local Phase Chat Connect LCP IPCP tun command

  set device PPPoE:rl0
  set MTU 1460
  set MRU 1460
  set dial
  set crtscts off
  set speed sync
  disable lqr
  set echoperiod 30
  enable echo
  disable deflate
  disable pred1
  disable vjcomp
  disable acfcomp
  disable protocomp
  set log Phase LCP IPCP CCP Warning Error Alert
  set ifaddr
  set login
  set authname <your_authname>
  set authkey <your_authkey>
  set timeout 0
  add default HISADDR
  set server /var/run/internet "" 0177

You can enable ppp at bootup by adding this to /etc/rc.conf:


Or run ppp manually like this:

# /usr/sbin/ppp -quiet -ddial -nat myadsl

Should you still not be able to connect, please have a closer
look at /var/log/ppp.log. You may also want to

# tcpdump -i rl0

to see if the PADI/PADO/PADR/PADS handshake completes

Good luck!

Cordula's Web.

More information about the freebsd-questions mailing list